Missing texture after compiling

Sorry if this isn’t in the right place, I’ve never posted outside of the TF2 forums.

Let me first say, I’m not too experienced with modeling or qc. I know most of the compiling process however, since I was working on a player model project some time ago. Anyways, I wanted to remove the moustache from the Vive La France in Team Fortress 2, to better fit an appearance I was going for with my Engineer loadout. The models are class specific, meaning they each have their own fitted models, so his is the only one I’d like to replace. I managed to remove the moustache bit from the Engineers model (short2014_vintage_director_engineer), but when I recompile it using the modified ref qc, the textures aren’t showing up. I’ve spent the last four hours bugging around with various commands and strings, but still nothing. Also, the vmt and vtf files are unmodified at all.

http://i.gyazo.com/ea9f007855685804f03e02719c7942ac.png

Again, I’m not very skilled with qc editing, so apologies if a solution is right under my nose. Here’s my qc:


$modelname "workshop/player/items/all_class/short2014_vintage_director/short2014_vintage_director_engineer.mdl"
$model "body" "lod1_short2014_vintage_director_engineer.dmx.smd"
$cdmaterials "models\workshop\player\items\all_class\short2014_vintage_director\"
$hboxset "default"
$hbox 0 "bip_head" -5.133  -9.071  -6.282  4.906  0.000  4.530
// Model uses material "models/workshop/player/items/all_class/short2014_vintage_director/short2014_vintage_director.vmt"
$attachment "unusual" "bip_head" 0.00 0.00 0.00 rotate -0.00 0.00 0.00
$surfaceprop "default"
$illumposition 0.351 -0.113 73.379
$sequence ref "ref" fps 30.00

For $cdmaterials, is that the actual location of the vtf and vmt files?

I believe that’s the path relative to the tf folder, excluding the materials folder.

Unless that was a rhetorical question. Did I do something wrong with that command?

Edit: Does the command need to direct to the current in-game files, or a new set? Because it’s set to the in-game directory.

check the path of the compiled texture. i had an issue at one point where i had set the texture paths up incorrectly in max. very easy fix, once i figure out the problem.

I’ll be damned. I’m not sure what exactly I did differently this time around, but I reopened the model in Blender to look through the Source engine export settings and see if maybe I did something wrong the first few times, exported the model again and compiled it, and it works perfectly.

http://i.gyazo.com/1cb31ede1ad782933811519abd1bcc84.png

Thank you everyone for the suggestions.