Missing textures after downloading CS:S content addon

Hello guys ! So I just got gmod through the Steam Summer Sale, (hail GabeN) and after i got it, i immediately donwloaded the CS:S content addon for •••••••••.era.ee. But when i join a server, it still displays Errors and Checkerboxes of pink and black.

After this, I installed Halflife 2 content and Left 4 dead content, with no avail. Please, fellow Gmod users, Help a noob. :smiley:

btw this was where i got the textures http://kajar9.wix.com/•••••••••2

Things i tried: enabling CSS through the game controller icon ( has an x next to it)

Just buy CS:S. It’s even cheaper than normal right now. Those content packs are outdated.

Installed it wrong most likely.
And i dont think they are outdated. I dont think any models / materials have changed in the base css

I made sure that i installed it correctly. I put the CS:S addon folder to the addon folder correctly. Still no results.

Content packs won’t work, you need to buy CS:S on the same Steam account as Garry’s Mod

It still hasn’t updated to Steampipe.