Missing TF2 and CSS models.

Hello. I’ve looked pretty much everywhere and I couldn’t find a solution for this problem. Here, let me explain.

I’ll try to be very descriptive.

Frist, when I start the game, I get those messages on the console:

http://img23.imageshack.us/img23/7602/gmod1mod.png

Everything above “Not Playing a Local Game” appears instantly. Everything below, after a few seconds.
(I blacked out my profile name because the internet is such a dangerous place!)

http://img32.imageshack.us/img32/7679/gmod2.png

Even though everything appears on the spawnlist, I can’t actually spawn anything. Unless I’m on a multiplayer server, then I’m able to spawn those props, but they appear as "ERROR"s. Their collision boxes are not affected though.
Clicking on any of those, while on singleplayer, results in nothing. It’s not possible to “Undo” it, either.

http://img441.imageshack.us/img441/4641/gmod3.png

CSS Weapons appear to be ok (Probably because they are not props, they are effects), besides the horrible texture quality.

http://img109.imageshack.us/img109/5605/gmod4.png

Can’t spawn ragdolls either.
Also, notice, on the bottom left hand corner, “tf” and “cstrike” got a minus on their left. Clicking on the minus just changes it to a plus with no real effect. That means their spawnlists are empty.

http://img842.imageshack.us/img842/794/gmod5.png

Everything else seems to be working fine, as you can see on the image above.

***Stuff that may or may not be totally or partially relevant:

***I DID verify and defrag the cache for Team Fortress 2 AND Counter Strike: Source AND Garry’s Mod.
I disabled every workshop addon/mod.
Wiremod is still running, though. I downloaded it before the big Gmod update, but I kept it up to date, using SVN tortoise. It’s working perfectly.
TF2 and CS:S content were working before the big update AND a few days after it, but they suddenly stopped.
I DO own both TF2 and CSS (And Gmod, of course).
Both TF2 and CSS are running flawlessly.
My computer can run all those games on the highest settings.
Downloading Gmod/TF2/CSS is out of question (unless it’s the only solution), as the max download speed allowed at the moment here is around 100KB/S
I unninstalled Dystopia, Age Of Chivalry and a few other “source mods/games” recently. Probably before TF2/CSS stuff stopped working.

Thanks in advance.

Have you tried un-mouting the games and then re-mounting?

Yes. Nothing changed ,though.

I know how to fix this problem, go to your steam Library and right-click on the games and click Properties. Next, go to the Local Files tab in the Properties menu, and click “Verify Integrity of Game cache”. And wait until the verification is complete.

I did Verify and Defrag all three games before posting this, but didn’t work. Did it again and it worked. Weird. Thanks!