Mistaken with lighting on the flag model

Hello forum.

I had a very strange problem. I’ve been doing models for the Source Engine for about 8 years, but I’ve never encountered such a problem.

My task was to create a model of the flag, which somehow would sway in the wind. The only option is animation. I myself could not make it and just accidentally found content for UE4.
I successfully ported the model, applied a texture to it, added the animation and went to check in Garry’s Mod. But I was very saddened by the fact that the model is very strangely illuminated.

The model is only 1 polygon thick. I applied a texture with the setting $nocull 1 to it.
So I tried to make a double flag, where 2 copies of the flag are used to avoid using nocull, but the result remained the same.
So I tried to make a static flag, but again the same light appeared only when the polygons are directed to a certain plane.

I checked the model on the stock map construct, and also on my own. I changed the direction of the sun, -90 or -45, there was no difference.

Please, if anyone knows the problem … help me :surrender:

Here are my source files for 3ds max + qc / smd.
https://puu.sh/yyzCS/e979004c59.zip

Try adding $phong 1 to the vmt and try adding $opaque to the QC. Not sure if both of them will work, but try it

Download this smd and toss it in the same folder as the others.

Alter your qc so you have the two model lines shown instead of one and toss the $illumposition in there somewhere.


$Model "flag" "yacht_animated_flag.smd"
$Model "flag" "yacht_animated_flag2.smd"

$illumposition -43.39 0.00 0.00

Thank you for your answers. It looked like it was just necessary to add a phong to the VMT and the lighting became more correct.