[Modding/Help] GMA Files

Hello guys and girls of the Facepunch community. My name is Ryan, but people know me as NyteRev. For the past couple of days, I’ve been editing some sounds files for one of the servers that I play on Garry’s Mod (A TTT server to be more specific), and at the end of each round they manage to have a song playing for the 30 second break. Now due to preference wise, I’m not a particular fan of the music playing during theses rounds, so I took it into consideration that I would try to MOD the sound files. Before it used to be easy, I used to be able just go into the download section and notice that there a sound folder and just edit the files there and it worked in-game. However because this server has the sound file in a GMA format, I had to extract it out and then do my editing to the sound files and then turn it back into the GMA format.

Here what I did:

  1. Found out which file was the Sound GMA
  2. Extract the GMA using GMAD
  3. Once I had everything extracted I started editing the mp3 files. (I made sure that the sound remain the same time down to the millisecond and as well as make sure the file is the same name as when I first edited it.)
  4. Once I had everything setup I moved it back into GMA format. (I made sure the GMA file had the same name, as well as the same content that was put into the addon.json file)
  5. Once I had the GMA file I insert it back into the original file location (aka my downloads folder)

Now here the problem… upon joining back the server the server recognize that it’s not the actual file, although I changed the name to match what the original GMA file was and once the download is complete. It still has the original audio that is suppose to be played (and it overwrites the GMA I created although replicated in terms of having the same name and size of the original file). I tried editing from the file from the downloads folder as well as the addons folder when I had subscribed to the file (And yes I also remove the subscribe when I inserted it in, and it ignored the file and downloads it back into the downloads folder).

So my question is… does anyone know an overwrite/bypass to this problem, and if there isn’t any then it’s cool.

Thank you for reading and have a nice day.

Bumping the thread.

Have you tried to disable server downloads via the menu before joining?