Model Compile Error - "building single convex"

I’m trying to make a pod that the player can stand inside for Garry’s Mod. My model and physmodel are connected in the right position but the resulting physmodel has the wrong shape and can’t be entered in-game.

Here’s my full build log:

Here’s my blend and SMD files: https://github.com/ThePademelon/GModCryoChamber/tree/Issue/4/UniqueModel/models/UNCOMPILED


WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!

You need to fix this problem, it’s why your collision model is messed up. If you type “vcollide_wireframe 1” while in-game, you’ll probably see a collision model that covers the entire prop.

Each collision model piece must have all faces assigned to a single smoothing group. You can use the same smoothing group on multiple collision parts. You also need to make sure that no collision model piece has a dimension on any axis less than half an inch.

By smoothing group you mean “Flat” and “Smooth” shading options? I’m really not sure what you, or the documentation for that matter, is talking about.

My collision model is all one part in blender and has no single-face components. From what I’ve read, it needs to be in separate simple shapes, but I’m not sure how to export them all as a single SMD so I’ve just left it as a whole, is that the problem?

Sorry if I’m completely hopeless, thanks nonetheless.

I don’t know how blender implements smoothing groups, but I don’t think shading is what you’re looking for. This probably won’t help, but here’s a screenshot in 3ds max:

You need to select all polygons in the object and assign them to a single smoothing group as shown on the bottom right of the screen. It doesn’t matter which smoothing group, as long as all polygons are in the same smoothing group.

In order to have a model which has open space inside it, you’ll have to use multiple single convex pieces to represent concave space. All of the smaller pieces will need to have their pivot origin and pivot angles be in the same place in the model (usually at the model origin) or the collision pieces will be in errant places when the model is compiled.

Usually to export multiple objects as a single SMD, you just select all of the objects before you use the export to SMD function, at least that’s how 3ds max works.

Thanks so much for this post. Unfortunately I’m not using 3DS Max and will have to figure out how to do the same in Blender. This is however a great post, thank you.

Update! By setting my collision model to the smooth shading group and splitting up my mesh into separate simple shapes (but still the same mesh object in the outliner, see below) my collision model now compiles!

http://puu.sh/ueyvC/e5ae6c9163.PNG

I’m not sure if this is because my collision mesh had inconsistent shading groups on it’s faces, and setting the shading group on all the faces consolidated the whole mesh to the same shading group or if it’s because smooth is the opposite of my visual model’s shading group (flat).

Either way, I hope that if someone else comes across this problem that they find this post and it helps them out.