Model compiling errors

Using GUIStudioMDL 2.2

Target Mod is Half Life 2

Already tried deleting Source SDK and reinstalling it, verified files.

Already restarted computer.



GUIStudioMDL 2.2/Source - © 2007 Neil 'Jed' Jedrzejewski - http://www.wunderboy.org/

Loaded QC file - "C:\Users\Henry\Documents\boingboing_model\compile .qc"

Created command line: "C:\Program Files (x86)\Steam\steamapps\henrytran123\sourcesdk\bin\e p1\bin\studiomdl.exe" -game "c:\program files (x86)\steam\steamapps\henrytran123\half-life 2\hl2" -notxbox C:\Users\Henry\Documents\boingboing_model\compile. qc

SteamStartup() failed: SteamStartup(0xf,0x0018F170) failed with error 108: The local Steam Service is not running

Created command line: "C:\Program Files (x86)\Steam\steamapps\henrytran123\sourcesdk\bin\e p1\bin\studiomdl.exe" -game "c:\program files (x86)\steam\steamapps\henrytran123\half-life 2\hl2" -notxbox C:\Users\Henry\Documents\boingboing_model\compile. qc

SteamStartup() failed: SteamStartup(0xf,0x0018F170) failed with error 1: Failed create pipe: 6, Win32 Error 6 "The handle is invalid."

Created command line: "C:\Program Files (x86)\Steam\steamapps\henrytran123\sourcesdk\bin\e p1\bin\studiomdl.exe" -game "c:\program files (x86)\steam\steamapps\henrytran123\half-life 2\hl2" -notxbox C:\Users\Henry\Documents\boingboing_model\compile. qc

SteamStartup() failed: SteamStartup(0xf,0x0018F170) failed with error 1: failed to take master pipe connection lock

Created command line: "C:\Program Files (x86)\Steam\steamapps\henrytran123\sourcesdk\bin\e p1\bin\studiomdl.exe" -game "c:\program files (x86)\steam\steamapps\henrytran123\half-life 2\hl2" -notxbox C:\Users\Henry\Documents\boingboing_model\compile. qc

SteamStartup() failed: SteamStartup(0xf,0x0018F170) failed with error 1: failed to take master pipe connection lock

The first error is from Steam not being open, the second one I have never seen before, but the last 2 you just need to restart Steam to fix.

Heres how I got these steps: Ran GUIStudioMDL without steam. Obviously that didn’t work.

Ran Steam, then ran GUIStudioMdl. Didn’t work.

Restarted Steam and then opened up Source SDK, then ran GUIStudioMdl. Didn’t work.

Restarted Steam, opened Source SDK, and opened Model Viewer. Didn’t work.

Edit: Resolved, redownloaded steam for the 3rd time. (3rd time’s the charm)