Model Error/Texture But They're There

Hi all,

So basically I have this model which has worked for me with no problems in GMOD 13. But I’m redoing my content pack for my server. For some reason it comes up pink and black textures, and on other computers it just comes up as errors, I’ve tried to get as much info as I can, if you want me to do anything, feel free to ask:

Model Location: GarrysMod\garrysmod\addons\ModelsPack\models\player
Model Files:

  • robber.mdl
  • robber.phy
  • robber.sw.vtx
  • robber.dx90.vtx
  • robber.dx80.vtx
  • robber.vvd

Material Location: GarrysMod\garrysmod\addons\ModelsPack\materials\player\robber
Material Files:

  • citizen_sheet.vmt


"VertexLitGeneric"
{
	"$basetexture" "models/player/robber/citizen_sheet"
	"$bumpmap" "models/player/robber/citizen_sheet_normal"
	"$halflambert" 1
}



  • citizen_sheet.vtf
  • citizen_sheet_normal.vtf
  • ted_facemap.vmt


"VertexLitGeneric"
{
	"$basetexture" "models/player/robber/ted_facemap"
	"$bumpmap" "models/player/robber/ted_facemap_normal"
	"$halflambert" 1
}


  • ted_facemap.vtf
  • ted_facemap_normal.vtf

As a player model it looks like what I described above ^

But when I spawn in as a ragdoll I get this in console:



Requesting texture value from var "$basetexture" which is not a texture value (material: pp/copy)


How can I fix this?
Thanks,
Computer600

Uh tell me. How does this “materials\player\robber” equal to this? “models/player/robber/”

Model code is finicky. Sometimes it accepts both slashes, even in the same line, and sometimes it throws a hissy fit. I’ve yet to find consistent logic as to when it needs to be which in vmt and qc files. But it’s best to be consistent to be safe.