Model has purple and black eyes

So I’ve been trying to do a friend a favor but it is always ruined by an error I always get whenever I compile a model that has eyeposing (or even has eyes at all)

http://cubeupload.com/files/c5e800purpaheyes.png

Im sure others have gotten this problem, I’ve lurked around the forum and have gotten shit.

Is there a way to fix this?

Pink and black checkerboards mean missing materials in source.

Edit:

Yeah if you would have set up materials in the model / folder structure correctly most likely.

no really…

and this uses materials from “models\humans\male” where the eye textures are.

Did you remember to assign the textures to the eyes?
Also, doublecheck .qc and .vmt’s for faulty folder structures, like // or \ or typing mistakes.
Might have something to do with the .qc, as you get it everytime you compile stuff with eyeposing. Maybe your decompiler is outdated/broken and can’t build a .qc properly?
Unless of course you make them yourself, then you might have forgotten a line or two.

Now I don’t normally make QC files myself but I checked and found nothing wrong with it.

Though there is most likely something wrong with this part that I keep missing

$model “male_07” “deriinavest.smd” {
//-doesn’t work eyeball righteye ValveBiped.Bip01_Head1 -1.220 -3.387 72.857 eyeball_r 1.000 4.000 Shirt 0.630
//-doesn’t work eyeball lefteye ValveBiped.Bip01_Head1 1.220 -3.387 72.857 eyeball_l 1.000 -4.000 Shirt 0.630
mouth 0 “mouth” ValveBiped.Bip01_Head1 0.000 1.000 0.000
}
$model “grenades” “grenades.smd” {
mouth 0 “mouth” ValveBiped.Bip01_Head1 0.000 1.000 0.000
}
$model “grenades” “UnknownModelName.smd” {
mouth 0 “mouth” ValveBiped.Bip01_Head1 0.000 1.000 0.000
}
$cdmaterials “models\humans\male”
$cdmaterials “models\Humans\male”
$cdmaterials “models\Humans\Male”
$cdmaterials “models\humans\Male”
$cdmaterials “models\Humans\deri101vest”

i dont know what your talking about but he looks like a fucking pimp with jewels in his eyes!

You need these lines:



$model "studio" "Yourheadhackhere_reference.smd" {
     flexfile "mdldecompiler_expressions.vta" {
	eyeball righteye "ValveBiped.Bip01_Head1" -1.28 -3.23 66.54 "eyeball_r" 1.00 4 "pupil_r" 0.63
	eyeball lefteye "ValveBiped.Bip01_Head1" 1.47 -3.23 66.54 "eyeball_l" 1.00 -4 "pupil_l" 0.63
     mouth 0 "mouth"  ValveBiped.Bip01_Head1 0.000 1.000 0.000

$attachment "mouth" "ValveBiped.Bip01_Head1" 0.80 -5.80 -0.15 rotate 0 -80 -90

and this goes under $surfaceprop:

$eyeposition 0 0 70



But don’t use the lines I just gave you because it’s different with each model (Well most of the time)

To get the lines you need you need to use QC Eyes in your Source SDK folder. To get what you need to fill in you need to select the center vertex (Or face, edge etc but vertex preferably) and get the coördanits of it. Don’t forget the change the “,” you get into “.” otherwhy’s QC Eyes can’t read it. Then once you selected all your settings you want you press generate qc and put the lines you get in your qc.

Im interested in learning how to fix this too, im still pretty amatuer, and this has been popping in alot of things ive been working on, it’s really frustrating, mostly when i decompile playermodels, it messes up the eyes.