Model invisible ingame

I recently worked on a model and after rigging and compiling it, it is invisible in game. Any idea why?

check the textures, vmt should be vertexlitgeneric,

I looked it over and everything is set properly. This is what my folder looks like currently:

I’m really new to this and at this point I am completely lost on what I did wrong.
Requesting texture value from var “$basetexture” which is not a texture value (material: pp/copy)
I am getting this error in game, however I am not sure if it is related to my model or not.

pp means post process and that error is just a general GMod error that pops up all the time. Try dropping a material and/or your QC on pastebin.

Here you are, thank you for your help. It is greatly appreciated.

QC: http://pastebin.com/hrJuzc8u

SMD Folder:

Main body material and VMT (Though there are other materials):

Model: http://i.gyazo.com/c7fddfd4fc731a967e16ffaed6f0e818.png

This probably isn’t the cause of her being invisible but she’s missing smoothing groups. It might also help to reset her xform, move it under her skin modifier and collapse it, and then reset her skin modifier (go to advanced parameters in the skin modifier and uncheck / check “always deform”).

Anyway, I’m not seeing any immediate issues. What did you compile the model with?

I complied the model with GUI Studio. I am curious about something however. This model was orignally based off of Staff Sergeant Apone and was formed to the shape of a woman, along with the sleeves being moved up, and the arms being replaced with more female ones, however I am still using the original textures instead of unwrapping them and recreating them. Would this be the cause? I may not respond anymore tonight due to the time, however I will be able to respond tomorrow. Thank you for the help so far.

can you please open the vmt for the body and show us what’s inside?

I did so above. Here is the link again: http://pastebin.com/HADC9w2s

can you please show us the compilation log?

btw, I just saw something on your qc.


$modelname "player/marine/female/femalemarine_01.mdl"

I don’t think it’s a problem but I haven’t seen this way of model name before. I usually do just


$modelname "<name here>.mdl"

Here you are: http://pastebin.com/ivhGgUFq

[editline]14th April 2015[/editline]

I’ll change the model name. That is how the person showed me in the tutorial so I assumed it was correct.

yeah, It doesn’t seem to be a texture problem.


writing C:\Program Files (x86)\Steam\steamapps\common\GarrysMod\garrysmod\models/player/marine/female/femalemarine_01.vvd:
vertices         0 bytes (0 vertices)
tangents         0 bytes (0 vertices)
total           64 bytes

vertices count is zero. you might want to try what captbigbutt said about the xform. and try using crowbar for compiling.

Yeah, I did try that though I did not see a change in the model. Ill compile and put it in game once I get back to my computer. Thank you for the help.

GUIStudioMdl and Crowbar aren’t compilers, they just add a GUI to studiomdl, but the real question is what version of studiomdl you end up using.

ah, I guess I’m mistaken.
anyways, that’s all I know. good luck with your port : D.

2.2 I believe.

I’ve tried everything and still nothing. I have no fucking clue what is wrong.

Let me rephrase. I’m looking for an engine branch or game/program. Is it the compiler for hl2, source sdk base 2013, sfm? etc

SDK, though I am going off of the Orange Box as the SDK version.