Model not appearing?

Well, I made a model. It’s a simple rectangle with one texture on it. This is what I have, and where it is:
ObamaTarget.smd - C:/Models/ObamaTarget
ObamaTarget_collision.smd - C:/Models/ObamaTarget
ObamaTarget.sm3d -C:/Models/ObamaTarget
ObamaTarget.JPG - C/Program Files/Steam/Steamapps/username/Half-Life 2/HL2/Materials/Models/ObamaTarget
ObamaTarget.VTF - C/Program Files/Steam/Steamapps/username/Half-Life 2/HL2/Materials/Models/ObamaTarget
ObamaTarget.VMT - C/Program Files/Steam/Steamapps/username/Half-Life 2/HL2/Materials/Models/ObamaTarget

And here’s my compile.qc


$cd "C:/Models/ObamaTarget/" 
$modelname "ObamaTarget.mdl" 
$cdmaterials "models/ObamaTarget" 
$scale 1.0
$surfaceprop "Flesh"

$body "Body" "ObamaTarget.smd" 

$sequence "idle" "ObamaTarget.smd" fps 30 

$collisionmodel "ObamaTarget_collision.smd"

{
$mass 40
}


and HERE’S the GUIStudio Compile log:


Created command line: "C:\Program Files\Steam\steamapps	aconinja1995\sourcesdk\bin\ep1\bin\studiomdl.exe" -game "c:\program files\steam\steamapps	aconinja1995\half-life 2\hl2" -notxbox C:\Models\ObamaTarget\compile.qc

qdir:    "c:\models\obamatarget\"
gamedir: "c:\program files\steam\steamapps	aconinja1995\half-life 2\hl2\"
g_path:  "compile"
Working on "compile.qc"
SMD MODEL C:/Models/ObamaTarget//ObamaTarget.smd
SMD MODEL C:/Models/ObamaTarget//ObamaTarget_collision.smd
WARNING: Bad collision model, check your smoothing groups!!!
aWARNING: Truncating model!!!!
WARNING: C:/Models/ObamaTarget//ObamaTarget_collision.smd has bad smoothing groups
Model has 1 convex sub-parts
Collision model completed.
---------------------
writing c:\program files\steam\steamapps	aconinja1995\half-life 2\hl2\models/ObamaTarget.mdl:
bones          708 bytes (1)
animations     116 bytes (1 anims) (1 frames) [0:00]
sequences      220 bytes (1 seq) 
ik/pose        164 bytes
eyeballs         0 bytes (0 eyeballs)
flexes           0 bytes (0 flexes)
textures        72 bytes
keyvalues        0 bytes
Collision model volume 1.00 in^3
collision        0 bytes
total         1464
---------------------
writing c:\program files\steam\steamapps	aconinja1995\half-life 2\hl2\models/ObamaTarget.vvd:
vertices      1152 bytes (24 vertices)
tangents       384 bytes (24 vertices)
total         1600 bytes
---------------------
Generating optimized mesh "c:\program files\steam\steamapps	aconinja1995\half-life 2\hl2\models/ObamaTarget.sw.vtx":
body parts:         8 bytes
models:            20 bytes
model LODs:        12 bytes
meshes:             9 bytes
strip groups:      25 bytes
strips:            27 bytes
verts:            216 bytes
indices:           72 bytes
bone changes:       8 bytes
everything:       421 bytes
---------------------
Generating optimized mesh "c:\program files\steam\steamapps	aconinja1995\half-life 2\hl2\models/ObamaTarget.dx80.vtx":
body parts:         8 bytes
models:            20 bytes
model LODs:        12 bytes
meshes:             9 bytes
strip groups:      25 bytes
strips:            27 bytes
verts:            216 bytes
indices:           72 bytes
bone changes:      16 bytes
everything:       429 bytes
---------------------
Generating optimized mesh "c:\program files\steam\steamapps	aconinja1995\half-life 2\hl2\models/ObamaTarget.dx90.vtx":
body parts:         8 bytes
models:            20 bytes
model LODs:        12 bytes
meshes:             9 bytes
strip groups:      25 bytes
strips:    Vº<}Y@        27 bytes
verts:            216 bytes
indices:           72 bytes
bone changes:      16 bytes
everything:       429 bytes
---------------------
Generating optimized mesh "c:\program files\steam\steamapps	aconinja1995\half-life 2\hl2\models/ObamaTarget.xbox.vtx":
body parts:         8 bytes
models:            20 bytes
model LODs:        12 bytes
meshes:             9 bytes
strip groups:      25 bytes
strips:            27 bytes
verts:            216 bytes
indices:           72 bytes
bone changes:      16 bytes
everything:       429 bytes

Completed "compile.qc"


This is what happens when I place my model into hammer (since nothing appears in model viewer):

Error when exporting the SMDs by the looks of it.

[editline]04:48PM[/editline]

And you need to apply smooth groups to your collision model.

I don’t really know what you mean by “smooth groups”
(and BTW, congrats on making gold member.)