Model Texture Issue

Been working on my model for gmod, works for the most part however I am running into an issue with textures. I’ve been following mariokart64n’s tutorial and in his youtube video’s he ran into the same problem as I. Alas, his filefront is down so I am unable to download the fix that he used to fix .vmts.

This is my model with the textures not in the the right place.

http://puu.sh/64lnC.jpg

And this is the very same model with the materials in the correct space.

http://puu.sh/64lum.jpg

As you can see, the model becomes invisible for whatever reason and I have no idea why.

My .qc


$cd "C:\Users\Sexy Frog\Desktop\encore"
$surfaceprop "flesh"
$modelname "encore\encore.mdl"
$cdmaterials "models\encore"

$model studio "reference.smd"
$sequence ragdoll 	"ragdoll.smd" FPS 30 		activity ACT_DIERAGDOLL 1

$collisionjoints "phymodel.smd" {
	$mass 60.0
	$inertia 10.00
	$damping 0.01
	$rotdamping 1.50
	$rootbone "chest"

	$jointconstrain "r_thigh" x limit 0.00 0.00 0.00
	$jointconstrain "r_thigh" y limit -93.00 61.00 0.00
	$jointconstrain "r_thigh" z limit 0.00 0.00 0.00

	$jointconstrain "r_calf" x limit 0.00 0.00 0.00
	$jointconstrain "r_calf" y limit -12.00 91.00 0.00
	$jointconstrain "r_calf" z limit 0.00 0.00 0.00

	$jointconstrain "l_thigh" x limit -21.00 21.00 0.00
	$jointconstrain "l_thigh" y limit -93.00 61.00 0.00
	$jointconstrain "l_thigh" z limit -35.00 35.00 0.00

	$jointconstrain "l_calf" x limit -44.00 44.00 0.00
	$jointconstrain "l_calf" y limit -12.00 91.00 0.00
	$jointconstrain "l_calf" z limit 0.00 0.00 0.00

	$jointconstrain "l_foot" x limit -1.00 -1.00 0.00
	$jointconstrain "l_foot" y limit -28.00 28.00 0.00
	$jointconstrain "l_foot" z limit -1.00 -1.00 0.00

	$jointconstrain "l_arm" x limit -102.00 53.00 0.00
	$jointconstrain "l_arm" y limit -102.00 35.00 0.00
	$jointconstrain "l_arm" z limit -77.00 86.00 0.00

	$jointconstrain "l_forearm" x limit -68.00 68.00 0.00
	$jointconstrain "l_forearm" y limit -30.00 30.00 0.00
	$jointconstrain "l_forearm" z limit 1.00 100.00 0.00

	$jointconstrain "l_hand" x limit -77.00 77.00 0.00
	$jointconstrain "l_hand" y limit -12.00 1.00 0.00
	$jointconstrain "l_hand" z limit -1.00 1.00 0.00

	$jointconstrain "r_arm" x limit -102.00 53.00 0.00
	$jointconstrain "r_arm" y limit -102.00 35.00 0.00
	$jointconstrain "r_arm" z limit -77.00 86.00 0.00

	$jointconstrain "r_forearm" x limit -68.00 68.00 0.00
	$jointconstrain "r_forearm" y limit -30.00 30.00 0.00
	$jointconstrain "r_forearm" z limit -1.00 138.00 0.00

	$jointconstrain "r_hand" x limit -77.00 77.00 0.00
	$jointconstrain "r_hand" y limit -12.00 0.00 0.00
	$jointconstrain "r_hand" z limit 0.00 0.00 0.00

	$jointconstrain "head" x limit -66.00 66.00 0.00
	$jointconstrain "head" y limit -44.00 44.00 0.00
	$jointconstrain "head" z limit -48.00 48.00 0.00

	$jointconstrain "r_foot" x limit 0.00 0.00 0.00
	$jointconstrain "r_foot" y limit -28.00 28.00 0.00
	$jointconstrain "r_foot" z limit 0.00 0.00 0.00
}


and the majority of the .vmt’s I’m using have the exact same code, however obviously different file names at the end.


"LightmappedGeneric"
{
	"$basetexture" "models/encore/torsom_d"
	"$translucent" 1
}


LightmappedGeneric is designed mostly for materials used in mapping; try switching to VertexLitGeneric.

Remove “$translucent 1” from your VMTs. As the parameter’s name would suggest, it makes things translucent.

Works, thanks!