Model texture + other compiling issues

Where to start…

Ok well Ive recently got into modeling (always had an interest in it) and im having a few issues :confused:

So as a second ever model (once made a box with a picture on it, and managed to make in an addon for gmod) I decided to make a mallet (well looks more like a hammer) and it compiles successfully.

When i try look at it in SDK Model Viewer its not there? It was when i tried an earlier model.

And when i put it in game its the mallet with the purple and black checkers (missing texture)

Ok screenshot time :slight_smile:

Models:

http://img200.imageshack.us/img200/3727/modelsv.png

Materials:

http://img294.imageshack.us/img294/4686/materials.png

Compile Folder:

http://img695.imageshack.us/img695/4053/compile.png

Now you may have noticed im using cmd instead of GUIStudioMDL. I just do it because it only takes 1-2 seconds to complete :slight_smile:

comile.qc:


$modelname "mallet/mallet.mdl"
$cdmaterials "models/mallet"

$scale 1.0
$surfaceprop "Metal"

$body "Body" "mallet.smd"

$sequence "idle" "mallet.smd" fps 30

$collisionmodel "mallet_collision.smd"
{
$mass 40
}

If your interested the Bat code is:


@echo off
"C:\Program Files\Steam\steamapps\acronesf\sourcesdk\bin\ep1\bin\studiomdl.exe" -game "C:\Program Files\Steam\steamapps\acronesf\garrysmod\garrysmod" -notxbox "C:\Documents and Settings\Justin\Desktop\mallet\compile.qc"
echo.
pause

I hope ive given enough info. Tell me if i’ve missed anything.

Thanks in advance!
AcroneSF

No calling me a noob please. Im rather new to this


$modelname "models/mallet/mallet.mdl"

you tried that? been a long time since i last did any of this but just a suggestion. Also make sure you applied textures to the mallet properly before exporting it

It didnt work :confused:

All it did was create a folder in the models folder. So it went:
C:\Program Files\Steam\steamapps\acronesf\garrysmod\garrysmod\models\models\mallet

Thanks anyway

Ive been getting same problems with my models

Show the content of the VMT’s. It could be something simple as a misplaced path

hmmm this is the code I use for when I compile props see if it works using this as a template:


$cd "C:\Program Files\Steam\steamapps\dxp214\sourcesdk\bin\ep1\bin"
$modelname "armourkey.mdl"
$model "studio" "armourkey.smd"
$cdmaterials "models\armourkey\"

$hboxset "default"
$surfaceprop "metal"
$keyvalues  { prop_data { "base" "metal.Small"  } } 
$sequence idle "armourkeyskeleton.smd" fps 1.00
$collisionmodel "armourkey.smd" {
	$concave
	$mass 0.2
	$inertia 1.00
	$damping 0.00
	$rotdamping 0.00
}


ah yeh $cd is important.

Stone VMT:


"VertexlitGeneric"
{
	"$basetexture" "models/mallet/stone"
}


Wood VMT:


"VertexlitGeneric"
{
	"$basetexture" "models/mallet/wood"
}


[editline]08:43PM[/editline]

Ok i tried that, renamed a few things and put the smd’s in the ep1/bin folder. Used cmd first, my computer beeped but it said it completed. The mdl and all the rest was in the gmod models folder.
Tried it with GUIStudioMDL 2.2 and it froze :confused:

[editline]08:45PM[/editline]

Ok well I’m off to bed. Night all and thanks for helping… I spose ill have to look at it when i get back (im leaving for 3 days) so ill read posts in 3 days.

Untill then… Bye :smiley:

I might actually get a chance to have a read over some posts in the morning…

Anyone else have some ideas?

upload, or pm me your source files, so I can check what’s wrong.

Sent them.

haha got it! all i had to do was compile it into the HL2EP1 folder instead of the Garry’s Mod folder