Model Texturing Problem

so latelly ive been porting a model of Mickey mouse and the models works i just cant get the texture right in blender it shows this as the material being used

But in the folder where the model iwas using there are only these textures

So what i do is i just make VTFs and VMTs for all of them

With no luck i decide to go through and rename each version of the VTFs and VMTs

I try this with all versons of the textures and they all still show up as

So i came here to get some help from the pros or atleast have you guys tell me what my noob mistake was, thank you
I tried to make this as detailed as possible, hopefully i wont have to wait 2-3 days to get a post, again…

Check your .qc file to see if the $cdmaterials matches with the current material folder.

I’m Pretty sure i have it set correctly, if not it’s my bad

It seems the folder names are correct. However, for some reason, you put in the materials folder in the addon folder, which is generally only .gma files are suppose to be there. You should instead put the materials folder in the main garrysmod folder. Something like this.
http://i.imgur.com/8BFMoLj.png

Notice that the materials folder is in the garrysmod (lowercase one) folder not in the addons folder. Try that and it should work.

i tried this and still got missing textures

What i tried after that is i re-compiled the model with

And yet i still got missing textures

You are suppose to put the materials folders in the garrysmod(lowercase one) folder not in the addon folder. That’s why the materials aren’t showing up.

The materials should be fine in the /addons/<addon-name>/materials folder. In fact, it has to be that way if you intend on putting it in the workshop.

What’s most likely wrong is the way you have the materials set up in your modeling program. To check: open up the uncompiled .SMD in a notepad program, it should say the name of the materials used many times over

pas[odk

[editline]16th March 2016[/editline]

trying now

[editline]16th March 2016[/editline]

yes, it does but as ive established there is no “MickeyMouse” texture in the root folder

That would be the problem! The SMD is looking for the texture “MickeyMouse” when it should be looking for “Mickey_Mouse_D” or with _N or _S where needed. You’ll have to set it up correctly within the Modeling program then export it again

True, that was, in fact, the old way of how Garry’s Mod sets up an addon before Steam Workshop.
I am saying you can also put the materials folder like this. Ex: garrysmod/materials/<name-of-addon> and it will still work.

I renamed the material in blender and exported it again

It still did not work

Your current material path is addons/MickeyMouse/models/Communist/Mtext, if I am correct.

And your current $cdmaterial is models/Communit/Mtext.

You should probably either modify the $cdmaterials to MickeyMouse/models/Communist/Mtext or omit/delete the MickeyMouse folder in order to match up with the current material path.

didnt work, whatever, there’s an obvious communication gap here i think its just time for me to give up on trying to make models, thanks for all the help, maybe ill try again in a few months

[editline]17th March 2016[/editline]

i actually thought of something, is it that the original model the .obj doesnt actually have a model applied to it it just reads the textures throught the .mtl? or am i just spitting out dumb ideas

Have you checked your vmts for errors?

How are you able to check vmts for errors?

Do you have VTFEdit?
If you use that to open the vmt files they probably will look similar to this:


"vertexlitgeneric"
{
    "$basetexture" "models/Mickey/MickeyMouse"
}


Mine looks like:



"VertexlitGeneric"
{
	"$basetexture" "Users/Jesse/Desktop/501p2model/cgi_phase2_501st"
}


[editline]17th March 2016[/editline]

I believe some of my file names have spaces(Don’t ask why xD), just gonna try replacing them with underscores.

Yes i did

Ok it would make sense if I changed that to the Model ahahaha.

You’ve changed the file names haven’t you? “Mickey_Mouse_D” would need to be “MickeyMouse” aswell, if thats what you changed it to.

Edit:
What are the other textures files for? Things like the normals are specified in the base texture’s vmt and don’t need their own one.