Model troubles: Can both sides of a face be textured?

I’ve been recently attempting to port some models into source from the PC version of Sonic Adventure to be used in the map I’m working on. I’ve been trying to get a tree model converted over; it’s basically just a trunk with a series of rectangular overlapping faces with foliage textured on them. (I know there’s better tree models out there I’m just trying to stick as close to the original as possible).

http://i2.photobucket.com/albums/y31/john41/th_treeimage.jpg

Now in SA the foliage was textured on both sides of the face and that’s how I had the texture set up in max, however, the resulting model only had the texture on one side and not the other. First question: is it even possible for a model to have both sides of a face textured in source and if so how? If not is there an alternative?

http://i2.photobucket.com/albums/y31/john41/th_newmodeltester0006.jpg

I’ve also been having some trouble with my transparency settings for the texture. The areas of the foliage that I wanted to be transparent are indeed see-through but I can also see the trunk of the tree as clear as day through the foliage – as if it were on top if the foliage.

http://i2.photobucket.com/albums/y31/john41/th_newmodeltester0005.jpg http://i2.photobucket.com/albums/y31/john41/th_newmodeltester0007.jpg

The texture looks like this right now with no alpha:

http://i2.photobucket.com/albums/y31/john41/th_Tree_gamma_old.jpg

Second question: how would I set up the alpha to get rid of the black sections without the above weirdness?

Thanks for your help

Add “$nocull” “1” into your vmt and it’ll render the texture on both sides of the face.

There’s no easy way to fix that overlapping transparency problem apart from using “alphatest” “1”, atleast I think so.

Thanks, the “$nocull” command worked great. I’m not quite familiar with all the vmt settings yet. I don’t know what to do about the alpha - I’ll mess around with it a bit more and see what I can come up with.