"Model uses STRIP_IS_QUADLIST_REG - will crash in this engine" error when i put face flexes on ragdoll

Yo sup any of u guys no wat this error means in gmod?

“Model uses STRIP_IS_QUADLIST_REG - will crash in this engine - so not loading!”

my model is invisible in game you can spawn it and hear the body collisions and pick it up but it’s invisible it’s linked to the faceflexs somehow. when i remove the faceflexs its visible with no errors so yeah anyone know how to fix it?

What is with you and getting all these bizarre errors. :v:

Post a link to your VTA file, it may be unfinished, corrupted or have an illegal symbol.

i dont know :stuck_out_tongue:

[editline]17th August 2014[/editline]

well about the vta my friend has it ill ask her. if my steam stop disconnecting me from the server :stuck_out_tongue:

I have the link for the VTA http://www.mediafire.com/download/3dlcw53c3394a32/elsavta.zip
It only happens when face flexes are implemented, here’s the QC for it.


$model "body" "elsa_reference.smd" {

	flexfile "elsa.vta" 
	{
		defaultflex frame 0
		flex "blink" frame 1
		flex "winkR" frame 2
		flex "winkL" frame 3
		flex "eyesclose" frame 4
		flex "pupilSM" frame 5
		flex "pupilL" frame 6
		flex "pupilR" frame 7
		flex "pupilLG" frame 8
		flex "pupilWideL" frame 9
		flex "pupilWideR" frame 10
		flex "LookLeft" frame 11
		flex "LookLeftL" frame 12
		flex "LookLeftR" frame 13
		flex "LookRight" frame 14
		flex "LookRightL" frame 15
		flex "LookRightR" frame 16
		flex "LookDown" frame 17
		flex "LookDownL" frame 18
		flex "LookDownR" frame 19
		flex "LookUp" frame 20
		flex "LookUpL" frame 21
		flex "LookUpR" frame 22
		flex "surprise" frame 23
		flex "surpriseL" frame 24
		flex "surpriseR" frame 25
		flex "doubt" frame 26
		flex "doubtL" frame 27
		flex "doubtR" frame 28
		flex "a" frame 29
		flex "e" frame 30
		flex "i" frame 31
		flex "o" frame 32
		flex "u" frame 33
		flex "omegabox" frame 34
		flex "grin" frame 35
		flex "bigsmile" frame 36
		flex "regret" frame 37
		flex "browsup" frame 38
		flex "browupR" frame 39
		flex "browupL" frame 40
		flex "browsdown" frame 41
		flex "browdownR" frame 42
		flex "browdownL" frame 43
		flex "anger" frame 44
		flex "angerL" frame 45
		flex "angerR" frame 46
		flex "sadness" frame 47
		flex "sadL" frame 48
		flex "sadR" frame 49
		flex "cheerful" frame 50
		flex "cheerfulL" frame 51
		flex "cheerfulR" frame 52
		flex "serious" frame 53
		flex "seriousL" frame 54
		flex "seriousR" frame 55
		flex "capeOutIn" frame 56
	}

	flexcontroller blink range 0 1 blink
	flexcontroller winkR range 0 1 winkR
	flexcontroller winkL range 0 1 winkL
	flexcontroller eyesclose range 0 1 eyesclose
	flexcontroller pupilSM range 0 1 pupilSM
	flexcontroller pupilLG range 0 1 pupilLG
	flexcontroller LookLeft range 0 1 LookLeft
	flexcontroller LookRight range 0 1 LookRight
	flexcontroller LookDown range 0 1 LookDown
	flexcontroller LookUp range 0 1 LookUp
	flexcontroller surprise range 0 1 surprise
	flexcontroller surpriseL range 0 1 surpriseL
	flexcontroller surpriseR range 0 1 surpriseR
	flexcontroller doubt range 0 1 doubt
	flexcontroller doubtL range 0 1 doubtL
	flexcontroller doubtR range 0 1 doubtR
	flexcontroller a range 0 1 a
	flexcontroller e range 0 1 e
	flexcontroller i range 0 1 i
	flexcontroller o range 0 1 o
	flexcontroller u range 0 1 u
	flexcontroller omegabox range 0 1 omegabox
	flexcontroller grin range 0 1 grin
	flexcontroller bigsmile range 0 1 bigsmile
	flexcontroller regret range 0 1 regret
	flexcontroller browsup range 0 1 browsup
	flexcontroller browupR range 0 1 browupR
	flexcontroller browupL range 0 1 browupL
	flexcontroller browsdown range 0 1 browsdown
	flexcontroller browdownR range 0 1 browdownR
	flexcontroller browdownL range 0 1 browdownL
	flexcontroller anger range 0 1 anger
	flexcontroller angerL range 0 1 angerL
	flexcontroller angerR range 0 1 angerR
	flexcontroller sadness range 0 1 sadness
	flexcontroller sadL range 0 1 sadL
	flexcontroller sadR range 0 1 sadR
	flexcontroller cheerful range 0 1 cheerful
	flexcontroller cheerfulL range 0 1 cheerfulL
	flexcontroller cheerfulR range 0 1 cheerfulR
	flexcontroller serious range 0 1 serious
	flexcontroller seriousL range 0 1 seriousL
	flexcontroller seriousR range 0 1 seriousR
	flexcontroller capeOutIn range 0 1 capeOutIn

	%blink = blink
	%winkR = winkR
	%winkL = winkL
	%eyesclose = eyesclose
	%pupilSM = pupilSM
	%pupilLG = pupilLG
	%LookLeft = LookLeft
	%LookRight = LookRight
	%LookDown = LookDown
	%LookUp = LookUp
	%surprise = surprise
	%surpriseL = surpriseL
	%surpriseR = surpriseR
	%doubt = doubt
	%doubtL = doubtL
	%doubtR = doubtR
	%a = a
	%e = e
	%i = i
	%o = o
	%u = u
	%omegabox = omegabox
	%grin = grin
	%bigsmile = bigsmile
	%regret = regret
	%browsup = browsup
	%browupR = browupR
	%browupL = browupL
	%browsdown = browsdown
	%browdownR = browdownR
	%browdownL = browdownL
	%anger = anger
	%angerL = angerL
	%angerR = angerR
	%sadness = sadness
	%sadL = sadL
	%sadR = sadR
	%cheerful = cheerful
	%cheerfulL = cheerfulL
	%cheerfulR = cheerfulR
	%serious = serious
	%seriousL = seriousL
	%seriousR = seriousR
	%capeOutIn = capeOutIn
}


I’ve compiled the model with both crowbar and guistudiomdl. No errors show up in the compiling and in HLMV I can use faceposing fine. But when I load it in GMOD it shows as invisible and gives this error in the console "“Model uses STRIP_IS_QUADLIST_REG - will crash in this engine - so not loading!”. It’s shown up in every model I compile with face flexes attached. And while there is a “Blender Implicit” bone in the VTA I doubt that is causing it, since it’s happened to other models I’ve compiled that don’t have blender implicit.

i spoke for belle :slight_smile:

Huh! Everything seems just fine. I have absolutely no clue whatsoever what that error is or what it means.

Although there is this:


  0 "blender_implicit" -1

Check your skeleton and Armature modifiers.

thats on it already

[editline]18th August 2014[/editline]

should i try deleting it?

The source engine handles 3 types of primitives



 enum StripHeaderFlags_t
 {
	STRIP_IS_TRILIST		= 0x01,
 	STRIP_IS_QUADLIST_REG	= 0x02,		// Regular sub-d quads
 	STRIP_IS_QUADLIST_EXTRA = 0x04		// Extraordinary sub-d quads
 };


You need to triangulate the mesh because I don’t think gmod supports quads
link me the dmx and qc

Sure, here’s the most up-to-date Elsa at the moment. It uses SMDs though, not DMX. Hope that’s alright. https://www.mediafire.com/?p52xep9moef2g6c

What the hell

http://puu.sh/aYuyQ.jpg

Uhhhmm, no idea what that’s about… But I did realize I totally forgot to give you the proper folders to put her in as well as the textures! I’m sorry about that.
https://www.mediafire.com/?o80bk44b3gazg2r All the Textures and MDLs are in the “FrozenElsa-Anna” folder. Hope this helps!

Edit: Curious, what did you use to compile her? Also, once you compile her, her legs are on bodygroups atm.

standard studiomdl from episode 1 ill take a look again soon

yea we fixed it but dat cape doe

Ok, I know it’s necrophilia, but I have the same problem out of the shit nowhere.

One day I’m compiling models without a problem, but then source is acting up.
The problem is basically the same, the model doesn’t work in gmod, works like a charm in SFM and SFM model viewer.

It’s impossible that there are any quads here, but the older models I worked on, they compile normally and there’s no problem with them

I can’t download different SDK or verify the cache because I’m on uni net and my steam is blocked most of the time.

What am I supposed to do?

i had this issue aswell since a gmod update back in last summer. however, what fixed it for me was to take care that the model doesn’t have more then 128 joints (even if gmod supports up to 256 ones - as far as i know). that’s fucking ironic. a model with more then 128 joints will work fine in gmod, as long as it doesn’t have face flexes applied.

Using Left 4 Dead 2’s studiomdl once helped me resolve similar problem.

The model doen’t have more than 128 joints, it has 70 bones, and not all of them even have things skinned to them, so they should disappear during compiling.

Getting rid of faceposing didn’t help too. I guess I’ll wait till I can download SSDK 2013.

that’s weird. as you were speaking of sfm and hlmv, i assume you’re using the sfm compiler?
using the gmod compiler helped for me.

There is a gmod dedicated compiler?

Edit: Using SSDK 2013 solved the problem.