Models texture quick help?

the models loads fine and all. but i dont know how to get the texture on it. im kinda new to this. but i already have the vmf and vmt. i just need to figure out how to get the model to know where to find them. any help? do i do this in the .qc file. or do i do this somewhere else?

yes in your .qc you should have a line that looks somewhat like this:
$cdmaterials “models\dkparadoxs_materials”
This tells the model to look for its textures in
C:\Steam\Steamapps\dkparadox\hl2\materials\models\dkparadoxs_materials
So if you put your vmt and your vtf in that folder AND edit the vmt to correctly direct the model to the vtf it should work great!

tell me if you have problems because textures are a little hard to understand on your first model. :<

im trying to make a really simple meat cube

well i have the cdmaterials line in the .qc


$modelname "MeatCube/MeatCube.mdl"
$cdmaterials "models/MeatCube"

$scale 1.0
$surfaceprop "bloodyflesh"

$body "Body" "MeatCube_ref.smd"

$sequence "idle" "MeatCube_idle.smd" fps 15

$collisionmodel "MeatCube_phys.smd"

and my vmt file is


"LightmappedGeneric"
{
	"$basetexture" "models/MeatCube/MeatCube"
	"$surfaceprop" "BloodyFlesh"
	"%keywords" "MeatCube"
}

ive tried changing a few things. but nothing seems to work. i think the problem is my vmt. but i dont know what i did wrong. im guessing basetexture. but ive tried multiple directories.

first of all, you are using a bad shader, use “VertexLitGeneric” instead of “LightmappedGeneric”.

if changing that in the .vmt didn’t fix it, then go open your reference.smd in a simple text editor, and look for “MeatCube.tga”, if you can’t find it then do a find and replace on the texture that’s there and make it so.

Then re-compile and try again.

THANK YOU SO MUCH. ive been trying to figure this out for months now. i cant thank you enough!