Model's textures are messed up, how do I fix this?

I decided to post this as a seperate thread so I could get more help here.

http://www.wduwant.com/index_uploads/uploads/ce7df4c963.jpg[/thumb]
[thumb]http://www.wduwant.com/index_uploads/uploads/ebe797395fed.jpg

I have no idea if Source flips the normals and cause the textures to mess up because in 3ds max it doesn’t look messed up.I tried to compile the model with flipped normals and it didn’t fix anything.How do I fix this problem? does it has something to do with vtf setting?

Have you checked if there’s a $translucent parameter in your VMT for the model? If so, remove that.

Yes and none of the textures VMT has $translucent parameter but the hair texture has $alphatest parameter in the VMT.

You don’t have to use the normals in 3ds Max to have normals work in Garrys Mod. Try not using the normal maps in the Material Editor and only use the diffuses, but still have the vmt files use the normals and see if anything changes.

That does look suspiciously like borked mesh normals, not texture normals. Mind if we see the SMD?

You can have the SMD but let me get home first.Do you need qc and textures as well?

No, just the model. The QC/VMTs are fine, it’s an error with the model normals, I’m sure of it.

Since you said you don’t have $translucent or $alphatest on the body material then that’s the only other thing that could be causing that.

https://www.dropbox.com/s/ucucmfav61430kj/myproject.7z
Here is the SMD, qc and some textures in case someone wanna try to fix my model.
I have not finish rigging the model so it doesn’t have collision model yet.

The model is fine, the problem is because you have $nocull in the face VMT.

I have to put $nocull in the face VMT or else the inside of the dress can be seen through which is something which shouldn’t happen.
What should I do so I can “nocull” the dress without messing the model up?

[editline]17th August 2014[/editline]

So I remove $nocull from the models and the same thing still happens.
I have no idea why is it.Source must has flipped the UV so hard that it messed up everything.
Does it has something to do with using an old model compiler? I couldn’t use Crowbar so I used GUIstudioMDL instead which is very old now.

http://i.imgur.com/wMhelfY.png[/t]
[t]http://i.imgur.com/Wr9NyX2.png

It’s working fine for me although I did remove $contents and $scale from the QC since they aren’t needed. I doubt that had anything to do with it though.

As far as the materials go, you probably don’t really need a $phongexponenttexture without phong eve enabled. Phong requires a normal map as well. Stylized or other flat models can just use a solid 128, 128, 255 color as the normal map while your specularity texture can go in the alpha channel of the normal map.

It is weird that it works fine for you.What did you use to compile the model?

I just use studiomdl.exe for everything. More specifically it’s the source sdk bin 2013 folder dumped into my source sdk orangebox bin folder. Kind of a lousy fix after steampipe but it’s worked for me nonetheless.

I tried it too, without edits to the QC, and I compiled it with Crowbar and I could see it fine. But I noticed some texture stuff with the skirt part of the dress and socks. Here’s a highlighted photo to showcase the examples.

You’ll usually get minor artifacts like that when you rip / import a model from a different program. You can fix it by welding verts and/or fixing smoothing groups.

I tried to remove $contents, $scale from the qc and $phongexponentexture from the VMT yet I still get the same problem.I’m using studiomdl from Source SDK 2013 MP.

http://www.wduwant.com/index_uploads/uploads/48d291fd5d85.jpg

One thing I discovered is that when I shine a lamp at the model, the model will be semi-translucent.
CaptainBigbutt, could you send me the compiled model please?.I’m going to credit your name when I release this model.

I just drag and drop QC files onto a compile script. That’s not really worth crediting. In any case, I’d go ahead and fix up the anomalies and such. How does the model look in hlmv for you?

http://www.wduwant.com/index_uploads/uploads/d36c838336c.png

I’m using HLMV from Source SDK 2013 MP and all I get is the model with missing textures.In game the model looks like what I posted previously.

I usually use the SFM modelviewer. I’ve never even gotten the standard modelviewer to load models at all. Thanks to steampipe I had to dump my SDK base 2013 folder in Source SDK for compiling. Then I compile to SFM for hlmv testing and transfer the model manually over to GMod.