Modules not working in Linux

Now, I know that this will most likely have a very simple answer, but I have only just started with hosting servers on Linux (Ubuntu) and therefore know very little of the set up and how it all works

So the server runs perfectly, addons all load fine, lua scripts work, players can join etc…
However, I seem to be experiencing some problems with my modules; I require tmysql, cryptopp and gatekeeper for a few of my scripts and addons, although each time I start the server, I simply receive:

Similarly, gatekeeper could not be found. That was, however, until I found gmsv_gatekeeper_linux.dll
I had been wondering whether the linux modules were different, and I am assuming that they are (considering a linux version has allowed the module to begin working)

So my question is, are there linux versions of cryptopp and tmysql?
I have seen on the GMod Modules svn, .lib files and others, so if you would mind telling me what I require (with a download link if possible please), then it would be much appreciated :slight_smile:

Also my modules are currently set up as the following, please say if there is anything wrong with them:

You downloaded the wrong module. A linux module would be an .so file.
.dll is for windows.

That’s what I thought… until the .dll gatekeeper_linux module worked on linux (I know it was edited but it’s still a .dll file)

Also do you have any links for the .so files please?

Have you tried this?

I don’t know about cryptopp though.

Thanks, I couldn’t find a linux version of tmysql (maybe because I was looking in tmysql2 before :L ) so I’ll try it out in a bit

[editline]6th December 2011[/editline]

Right, I installed gm_tmysql_linux.dll and deleted the old gm_tmysql.dll
However, I got the following error:

Linux GMod modules have to have the dll extension too. They’re just renamed so files.

So by updating the boost files on the linux server, the error has now changed to:

Help would be much appreciated with this :frowning:

now you need the 32bit libmysqlclient binaries since the 64bit ones cannot be used