Mono Config Paths Help (Linux)

Hi, recently I tried installing and running Rust servers on linux distributions Ubuntu 64 and Centos 64 instead of Windows OS, which was working fine. I used the following command to download the files via steamcmd. I’ve replaced my server key with xxx. app_update 258550 -beta stable -betapassword xxxxxxxx validate

After running that command, the files download and show as: bundles rust_server_Data rust_server.x86 rust_server.x86_64
. When I run the command ./rust_server.x86_64 , I receive the following output: **Set current directory to /home/steam/steamcmd/steamapps/common/rust_dedicated
Found path: /home/steam/steamcmd/steamapps/common/rust_dedicated/rust_server.x86_64
Mono path[0] = ‘/home/steam/steamcmd/steamapps/common/rust_dedicated/rust_server_Data/Managed’
Mono path[1] = ‘/home/steam/steamcmd/steamapps/common/rust_dedicated/rust_server_Data/Mono’
Mono config path = ‘/home/steam/steamcmd/steamapps/common/rust_dedicated/rust_server_Data/Mono/etc’
**
The odd thing is, when I download the server files by just using app_upgate 258550 without the server key, I still download all the files, and I still get the same mono config output when running ./rust_Server.x86_64

The even weirder part is that, with the password, everything worked fine on windows based OS. Without the password, I would get a txt file called wrongbranch. So, does anyone know how I can apply my key to the linux version of Rust? Everything worked fine on Windows.

Summary:

Just need to figure out how to link my server key with the files. Like I said in the original post, on windows, downloading from steamcmd with the password then running the server start file worked fine. On linux, the same files download whether you download with the password or not, and the same mono config lines are outputted when the server start command is ran. Very odd. Hope someone can help.