Mounting source games on my dedicated server.

Hi. I have a dedicated server. But none of the stuff from any of my source games is on there, no css, no EP2, no nothing. And by nothing I mean you cant spawn props from it. Even though I have them all.
There must be a file or something that I go into to mount these games.
Any help would be a appreciated.
Thanks.

–Sir Michael of Gmodshire.

You need to startup HLDSupdatetool with the right parameters for the game you want content from, as if you were running a server for that game. Then they’ll become available to gmod.

Do you have the content installed? If so, delete the contents in your cfg/content.txt and replace with:



"Content"
{
	"240"
	{
		"mount"		"1"
	}
	"300"
	{
		"mount"		"1"
	}
	"380"
	{
		"mount"		"1"
	}
	"420"
	{
		"mount"		"1"
	}
	"400"
	{
		"mount"		"1"
	}
	"440"
	{
		"mount"		"1"
	}
	"320"
	{
		"mount"		"1"
	}
	"280"
	{
		"mount"		"1"
	}
	"1300"
	{
		"mount"		"1"
	}
	"2400"
	{
		"mount"		"1"
	}
	"340"
	{
		"mount"		"1"
	}
	"360"
	{
		"mount"		"1"
	}
}

OK, I tried that, I’m connecting to my server now. :smiley:

I have CSS installed and it says its mounted when i start my server. Why is it not spawn able though?

I tried that content thing and it didn’t help me at all :frowning:

Could you explain that in a way easier to understand? :slight_smile:

[editline]06:27PM[/editline]

didnt wurkz

There is no easier way than the full explanation.

You didn’t download it yet or the cstrike folder is still in the server’s root game folder instead of orangebox.

Mine downloaded into my Srcds folder. Not orange box folder. I’ll move the cstrike to my orangebox folder then.

[editline]02:36AM[/editline]

Okay that did it.