Multiplayer not working

i tried joining a server in gmod (playling multiplayer in gmod for the first time) and when it FINALLY connected after getting 500 some files form the server, everything was f#@$ked up. i couldnt see anyone, my viewcamera was dragging on the ground , as if the player resizer was used on me and set to 0.01. i tried some other servers and the same thing was happening to me. why is this happening and how do i fix it?

Delete: garrysmod\garrysmod\cfg\config.cfg
Delete Al files in: garrysmod\garrysmod\cache\dua
Rename: Addons to Addons2
Rename: Lua to Lua2
And try again. If it still doesn’t work reinstall gmod. If it works then start be copying addons one by one from Addons2 to Addons untill you get the same bug again then remove that addon

will that delete my addons/lua? will they still work afterwards?

If it happened after joining the server, your best bet is to just clear the garrysmod\garrysmod\cache\dua folder, since you probably downloaded some client/shared lua that fucks up your game, and that’s where it’s stored. Doing this doesn’t remove any addons.