Multiplayer Updating

A few hours ago, I started up rust and clicked on play game, expecting to find all the servers I regularly join to pop up. Instead, in small text it said “Updating” and that has been there for a few hours now, I’ve been waiting, watching youtube videos and regularly checking back to see if it has “Updated” but the text just stays there and I cannot join any servers or Refresh…

If anyone knows if my game is actually updating or its just a bug please tell me!!

Thanks :slight_smile:

You could try a couple of things.

Make Rust a high priority game on steam which will automatically update it whenever it is available (although i think you’re experiencing a bug since no new updates have been released)
Try relogging steam, completely log off your account and log back in
check the files for integrity or whatever.
Reinstall.

Tried Reinstalling and nothing happened, I was expecting it to auto-update on install but it didnt seem to work, Ill go ahead and try the other stuff,

Thanks!

Had the same problem.

Just head into your steam library and manually download the update.

Sorry none of my ways worked for you man D: Hope it gets fixed.