Multiple Players Editing One Server?

My best friend and I bought Garry’s mod, because we had a blast with Halo 3’s forge mode, and love being able to edit and make humorous content together. We went for that today, I started up a server, and we went to make something hilarious.

We ran into a problem though. We figured that, since we both didn’t know Garry’s mod, at all, we could learn as much as possible by randomly dicking around. This wasn’t the case.

No matter how I set up the multiplayer server, it seems that only the host could edit, and spawn items. Through a lot of creative googling, we couldn’t figure out how to configure our server as to make it so we could both create and edit items.

So we turn to the forum. Can you please help us with this (so it seems) minor issue?

Thanks.

Before you guys start up the server, make sure to change all the options. When you choose a map; there’s a couple tabs at the top.

Make sure to change stuff like… Ragdoll count and such. See if that helps.

I usually set them all to max, I think 200, was it? Anyways, I’ll give it a second look, and post back with results. Thanks.

It didn’t work, Derek still can’t bring up the menu and spawn things. The menu doesn’t even come up when you hit Q, for either of us, when you aren’t the one hosting, but when I join someone elses server, I can.

When you first join the server, at least on the client that’s NOT hosting, it gives you a LUA error, but still lets you navigate and pick up things.

I have no idea how to edit my LUA, though. This urks me.

That’s not normal behaviour of the engine nor the gamemode, have you tried reinstalling?

We’re both getting the same problem, it couldn’t be my computer-centric, right?
Maybe it was because we were running a local server?

No, that still wouldn’t happen, I host a public local often and everyone can build fine.

You haven’t said whether or not it works in single player. My guess is it’s one of your addons.

Install an admin mod like assmod and give him admin. Don’t know about not being able to bring up the menu.

Verify files in Steam.

I said we were playing on a server I made, I don’t think you can multiplay in single player mode… ._.
And I don’t have any addons installed, I just freshly installed Gmod.

[editline]02:20AM[/editline]

Did that, way before even posting this thread.

Thank you, everyone for helping me with my little issue, I figured out my problem, and it was kinda dumb.

  1. When I was forwarding my ports, I updated my router, which reset my local IP addresses, making my forwarded ports completely wrong.

  2. The server I was running in the first place was perfectly fine, my stupid mistake, was, I wasn’t giving Derek my port. I was giving him ###.###.#.#, when I should have been giving him ###.###.#.#:#####.

Thanks again, we had lots of fun last night dicking around on gm_construct.

Rymar

Well, that doesn’t make any damn sense to me, but hey, if it worked…

So if you don’t forward ports you can’t build?

Huh, weird.