Multiple Problems with hosting a server.

For one, I keep getting (Couldn’t allocate a server IP) when I try to join my server.
Second, my server DOES NOT show up on the server list.
Third, no-one can join my server at all.
Here is a picture of my port forwarding screen, I’m 90% sure I’ve done it right:

http://img24.imageshack.us/img24/7682/pictureofportfoward.jpg

I use slayers dedicated server install, I’ve reinstalled it 3 times, so don’t tell me to reinstall it.
My Specs:
Intel® Pentium® Dual CPU E2200 @ 2.20 GHz
Memory (RAM) 4.00 GB
64-bit Operating System
Windows Vista Home Premium (64-bit)
Manufacturer: Hewlett Packard Company
I have Optimum Online and A Linksys WRT54G Wireless-G Broadband Router.
I need help, I don’t know what I’m not doing right at all.
PS. Please excuse the grammar mistakes.

bump… Come on guys, nothing works.

in cmd type

IPCONFIG/ALL

look for your ipv4 address

it says a lan ip

use that as the ip to foward to

http://img59.imageshack.us/img59/3259/goddamn.jpg

That is what I get when I try that.
Help?

Its Ipconfig all. There is a space not a /

Set Protocol to both, not TCP.

Does not help.

Gives me an overlap error.
I appreciate you guys trying to help… but nothing works…

On your SRCDS Port Forward entry, set it to UDP. NOT TCP.

Quake (thusly, Half-Life, and therefore, Source) uses UDP for connections.

If you have sv_lan 1 in your server.cfg your server is a LAN only server, and no one will be able connect that’s not on your local area network.
If sv_lan is 0 then it’s not a LAN server.

I’m assuming that sv_lan is 0, which means it’s a public sever, If you can’t connect you either need to change your servers ports or your clients.
Go to your garrysmod/garrysmod folder, not the dedicated server installation and go into the cfg folder, make an autoexec.cfg using notepad and add these lines.

You need to connect to your external ip address, which can be found here.

Your ports also need to be TCP and UDP, if their isn’t an option for both you must foward one as TCP and one as UDP.

I did everything you said.
I changed all of the ports to both.
I changed the gameport from 27000 - 27015 to 27000 - 27014, Changed it to both.
Changed the last one to both, also.
Will it work?
I got to use the thing. BUt noone can still connect. I checked the server.cfg, It says sv_lan 0.

Back to my idea

What are u using vista,xp ?

Vista. I think it has something to do with my classpath…
.;C:\Program Files (x86)\Java\jre6\lib\ext\QTJava.zip Is my classpath. I don’t get it, whats wrong?
Edit: I need a goddamn mod or something in here, like someone who’s overcome this before, Or knows about this.
Or maybe someone to check out my CPU and see what’s wrong, maybe use TeamV?

I fixed it for him

It has NOT be fixed. Please help me with this situation.

Ok, first thing that tipped me off, you said “my LAN server” THIS IS NOT RIGHT
sv_lan must be set to 0
All firewalls either have to be bypassed or shut off
Its best to just use DMZ on the machine you want to run the server off of
Are you running your server on the same machine you are playing Gmod or another steam game?

It’s ipconfig /all

And you only need ipconfig

Calm down chief. I didn’t mean it that way, you know it.

  1. sv_lan is set to 0. I’m not that dumb.
  2. All firewalls have been shut off.
  3. DMZ? I use slayers dedicated server installer.
  4. Different machine.
    My luck is bad.
    Your point is invalid.

Last Bump. sigh.