My CS:GO SDK Hammer is so broken. Grids and camera not working.

Namely, the four windows of the editor (the grids and camera).
They seem to be constantly rendering the wrong things as I drag my mouse across them. Sometimes the grids are showing what the 3D camera should be showing, and sometimes they show one of the other grids. To put things bluntly, it’s completely fucked.

I’ve recorded these strange happenings and uploaded them in a webm so you guys can really see what I’m talking about.
Link: http://s1.webmshare.com/eX4mV.webm

I’ve been Googling for a day or two, and I can’t find anything on forums/question sites that resembles my situation.

I’ve deleted the CSGO SDK, Reinstalled it, Verified Cache, and Rebooted. Nothing works. Source multitool just launches the CSGO SDK window.

I’m at the end of my rope guys. Please help.

Any programs interfering?

Not from what I can tell, I did have microsoft word open when I first discovered the issue, but I don’t have it open now, and it’s still happening.

It also says [READ ONLY] next to the file window when I create a new map. Don’t know if that’s significant but I don’t remember that being there normally.

The [READ ONLY] portion is normal. Does the flickering just happen in the CSGO Hammer Editor or all versions?

HL1 Hammer is fine. I haven’t checked the HL2 and other ones, I’ll go do that now.

[editline]24th February 2015[/editline]

Okay, so I launched Source multitool, first selecting Half-Life 2 in the Game\Mod drop down.

It returned the error: “Program cannot start because steam_api.dll is missing. Try reinstalling to fix this program.”
This was the same result I get from the Episode 1 & 2 Game/Mod launch options. I’m probably going to verify the cache of the games.

Source SDK Base 2013 Singleplayer & Multiplayer worked perfectly, as did the CSS option.

[editline]24th February 2015[/editline]

After verifying the original HL2 game cache it found 1 missing file (I can only assume this to be the alleged steam_api.dll), Source MultiTool was sucessful in launching hammer configured for HL2, and HL2 EP1 & 2.
I should also mention that I had previously run verification of CSGO’s game cache, and it found 6 missing files, which were redownloaded.

Unfortunately, CS:GO SDK’s hammer is still broke as shit.

So the other versions don’t have the flickering issue?

Nope.

Guess that narrows it down to just CS:GO then.

Have you tried verifying CS:GO?

Yup

It found 6 files, redownloaded them, and the hammer still doesn’t work properly.

Hmm, this is a tough one.

Alright then. If you haven’t already, try just quickly starting up CS:GO. Exit it and then start up Hammer and see if the issue persists.
(Odd thing to try I know, but Hammer does get touchy sometimes.)

I found this: http://steamcommunity.com/app/211/discussions/0/620700960938894659/?insideModal=1

This guy said it was Razer Coretex that was causing a problem. This bothers me, because I once had “Razer Core” installed on this computer, but it’s still present in my Add/Remove programs. I click uninstall, and it says that uninstall.xml is missing.

Now, I’ve tried fucking everything to get this thing off my machine now that I know it could be causing the problem. I’ve gone into regedit and deleted all the registery keys for Razer, but the Razer Core application is still there. What’s worse, I cant find anything about Razer “core” on their site, whic means they must not support it or its an older version of their software!

I experienced this problem some time ago, and could only ever solve it by completely re-installing Windows. This is probably not the solution you’re looking for, but it’s what worked for me, with all other methods appearing useless.

:suicide:
Curse you valve.

[editline]24th February 2015[/editline]

You guys aren’t going to fucking believe this, but I just turned Windows Aero mode back on, and now it works just fine.