My DarkRP Server Say Sandbox!

on the Server Menu when you see my server Its says Sandbox Insted OF darkrp 2.4.2! whats wrong Please help me

Did you actually LOAD the gamemode? Seriously. I’ve seen people just put the gamemode in the gamemodes folder and just start it and they start complaining. Did you also install the gamemode CORRECTLY?

Yes I did I Im using SVN For it Its Not broken or anything On Scrds It says DarkRp 2.4.7 I dont know whats wrong

Well… Your not the only one. I have a gamemode that I LUAed. Tested and it worked perfectly works on sp but not on mp. Tryed using “sv_defaultgamemode” “Runaway!” and it failed.

[editline]27th July 2012[/editline]

P.s i added the gamemode to addons and gamemodes… No work. sv_defaultgamemode went to server.cfg and it didnt work too.

snake i found the problem. When running the server, edit the shortcut of bat and add +sv_defaultgamemode DarkRp or what ever the gamemode you want it is

If it Works Thanks :smiley:

[editline]28th July 2012[/editline]

THANKS IT WORKS!!! MAN YOU ARE THE BEST!!! ps. It was darkrp 2.4.2

How do you Load the gamemode? I just SVN download, and i just started using my darkrp server! It works but shows as sandbox on Gmod main servers! HELP!

Make sure the darkrp gamemode folder is called darkrp not DarkRP or darkRP. IT needs to be all lower case. then change server.cfg to gamemode darkrp

Thanks! I did that, now how is the server.cfg suposse to look like?



//Server.cfg

hostport 27015 //Port used for the Server

Hostname "YOUR HOSTNAME" // Host name
rcon_password "1234" // rcon password

sv_password "" //Server Password


gamemode "darkrp"


//Voice Chat
sv_voiceenable 1 // Enable Voice
sv_alltalk 0 // Allow all the teams to talk to each other

// Lan
sv_lan 0 // Lol Lan

//Rates (Don't change unless you under stand these)
sv_maxcmdrate 33
sv_maxupdaterate 60
sv_maxrate 0
sv_minrate 2000
sv_minupdaterate 20


//Fall Damage, 1 for realistic, 0 for 10 hp
mp_falldamage 1

//How fast a Spray can be Sprayed, In seconds
decalfrequency 30000000

// LOGGING
sv_logbans 1
sv_stats 1
log 1 //Turn this off if you don't like the logging in the console (L <date> then some other stuff), logs are in garrysmod/logs

//Leave off unless you want them on. (Most things that crash servers are cheats.)
sv_cheats 0


"sbox_maxprops" "35"
"sbox_maxragdolls" "0"
"sbox_maxnpcs" "0"
"sbox_maxballoons" "0"
"sbox_maxeffects" "0"
"sbox_maxdynamite" "0"
"sbox_maxlamps" "0"
"sbox_godmode" "0"
"sbox_noclip" "0"
"sbox_maxhoverballs" "0"


sv_region 0
sv_timeout 65

//Make sure the Bans are loaded
exec banned_user.cfg


It says can not find gamemode “darkrp” when i put it in the gamemodes file plz help me