My dedicated server gamemode will not change from sandbox

Hi there i have a dedicated server on garrys mod but i cannot change the game mode from sandbox please could u help i drag other gamemodes into the gamemode folder and i done a bit of research and they says change it by server.cfg but i dont have 1 now i slightly confused :S

Okay, in

your GARRYSMOD Folder (Server’s)

Do this:

Goto your CFG Folder,

Create a new file, called server.cfg

In it, put the following:


sv_defaultgamemode "EXACTGAMEMODENAMEHERE"

Any questions, just ask :wink:

ok it changes the gamemode in the console but when i go onto my server on gmod its just gmod base gamemode when its meant to be deathrun please help

Then you have an error. You should post in the Questions subforum of the Lua Scripting forum asking how to fix it, along with the error, and the part of the file where the error has occured.

---- Host_Changelevel ----
SOLID_VPHYSICS static prop with no vphysics model! (models/props/cs_militia/lightfixture01.mdl)
SOLID_VPHYSICS static prop with no vphysics model! (models/props/cs_militia/lightfixture01.mdl)
SOLID_VPHYSICS static prop with no vphysics model! (models/props/cs_militia/lightfixture01.mdl)
SOLID_VPHYSICS static prop with no vphysics model! (models/props/cs_militia/lightfixture01.mdl)
SOLID_VPHYSICS static prop with no vphysics model! (models/props/cs_militia/lightfixture01.mdl)
SOLID_VPHYSICS static prop with no vphysics model! (models/props/cs_militia/lightfixture01.mdl)
SOLID_VPHYSICS static prop with no vphysics model! (models/props/cs_militia/lightfixture01.mdl)
SOLID_VPHYSICS static prop with no vphysics model! (models/props/cs_militia/lightfixture01.mdl)
SOLID_VPHYSICS static prop with no vphysics model! (models/props/cs_militia/lightfixture01.mdl)
SOLID_VPHYSICS static prop with no vphysics model! (models/props/cs_militia/lightfixture01.mdl)
SOLID_VPHYSICS static prop with no vphysics model! (models/props/cs_militia/lightfixture01.mdl)
SOLID_VPHYSICS static prop with no vphysics model! (models/props/cs_militia/lightfixture01.mdl)
SOLID_VPHYSICS static prop with no vphysics model! (models/props/cs_militia/lightfixture01.mdl)
SOLID_VPHYSICS static prop with no vphysics model! (models/props/cs_militia/lightfixture01.mdl)
SOLID_VPHYSICS static prop with no vphysics model! (models/props/cs_militia/lightfixture01.mdl)
SOLID_VPHYSICS static prop with no vphysics model! (models/props/cs_militia/lightfixture01.mdl)
SOLID_VPHYSICS static prop with no vphysics model! (models/props/cs_militia/lightfixture01.mdl)
SOLID_VPHYSICS static prop with no vphysics model! (models/props/cs_militia/lightfixture01.mdl)
SOLID_VPHYSICS static prop with no vphysics model! (models/props/cs_militia/lightfixture01.mdl)
SOLID_VPHYSICS static prop with no vphysics model! (models/props/cs_militia/lightfixture01.mdl)
SOLID_VPHYSICS static prop with no vphysics model! (models/props/cs_militia/lightfixture01.mdl)
SOLID_VPHYSICS static prop with no vphysics model! (models/props/cs_office/light_security.mdl)
SOLID_VPHYSICS static prop with no vphysics model! (models/props/cs_office/light_security.mdl)
SOLID_VPHYSICS static prop with no vphysics model! (models/props/cs_office/light_security.mdl)
SOLID_VPHYSICS static prop with no vphysics model! (models/props/cs_office/light_security.mdl)
SOLID_VPHYSICS static prop with no vphysics model! (models/props/cs_office/light_security.mdl)
SOLID_VPHYSICS static prop with no vphysics model! (models/props/cs_office/light_security.mdl)
SOLID_VPHYSICS static prop with no vphysics model! (models/props/cs_office/light_security.mdl)
SOLID_VPHYSICS static prop with no vphysics model! (models/props/cs_militia/lightfixture01.mdl)
SOLID_VPHYSICS static prop with no vphysics model! (models/props/cs_militia/lightfixture01.mdl)
Lua initialized (Lua 5.1)
Reverting sv_defaultgamemode to sandbox - gamemode is not valid.
Registering gamemode ‘sandbox’ derived from ‘base’
ScriptEnforce is disabled
Compressing lua files into data pack…
Skipped. Datapack exists.
Executing dedicated server config file server.cfg
Attempted to create unknown entity type weapon_m3!
Can’t init weapon_m3
Attempted to create unknown entity type weapon_m3!
Can’t init weapon_m3
Attempted to create unknown entity type weapon_m3!
Can’t init weapon_m3
Attempted to create unknown entity type weapon_m3!
Can’t init weapon_m3
Attempted to create unknown entity type weapon_m3!
Can’t init weapon_m3
Attempted to create unknown entity type weapon_m3!
Can’t init weapon_m3
Attempted to create unknown entity type weapon_m3!
Can’t init weapon_m3
Attempted to create unknown entity type weapon_m3!
Can’t init weapon_m3
Door door_outside_02 using obsolete ‘Start Open’ spawnflag with ‘Spawn Position’ set to ‘Open’. Reverting to old behavior.
Door door_inside_02 using obsolete ‘Start Open’ spawnflag with ‘Spawn Position’ set to ‘Open’. Reverting to old behavior.
Door door_inside_01 using obsolete ‘Start Open’ spawnflag with ‘Spawn Position’ set to ‘Open’. Reverting to old behavior.

This is the error i get can any one help?

Reverting sv_defaultgamemode to sandbox - gamemode is not valid.

You installed it or set the variable incorrectly.

how can i fix this please can u send it or some think thxs

No. Give us more info. Where’d you get it, where’d you put it?

i put the file into my gamemodes file and changed the gamemode in the console to match and i got the gamemode from drama ultimate

Doesn’t scare me why it doesn’t work. Most gamemodes are broken on drama unlimited.

Just make a new cfg called “autoexec.cfg” and put sv_defaultgamemode gamemodehere.

I still am sure he won’t get it to work, as the gamemode is bugged.

Learn to code or find a new gamemode to host.
Tip: Don’t ask “How do I fix it” unless you have the money for someone to fix it for you.

For Fuck sake you have been banned so much for this exact thing. Use the questions sub forum.

Also pirated the Gamemode…

Instead of being jerks and not helping, how about you actually help. Acting like you know whats up and not helping is just low.

This forum is for HELPING one another.

You revived a two year old thread that was posted in the wrong section, you proud of yourself?