My friend can't join my dedicated server

I created a dedicated server by SteamCMD but my friend can’t join it. It says “Server isn’t responding”.

and this are the ports I did.

Imgur

so what is the problem? please help I was looking for a solution for weeks :cry:

Hi,

Is your computer IP actualy 192.168.0.100 ? Check in cmd using ipconfig.
Also, make sure you didn’t block your gmod server in your PC firewall.
Be sure to give to you friends your Public IP too, that you can find easily on “what’s my IP” websites, as if you give them something starting with 192.168.x.x it is a private LAN IP so they won’t be able to join with that.

Good luck.

how to know if I blocked my server in the firewall? and how to unblock that?

I gave them Public IP starting with 51… and didn’t work, but my server IP is like this 192.168.x.x:27015, should the IP of the server change?

guys please help

Please answer, I really need a solution

Here is how to forward ports for gmod:

  1. Click (Windows button + R) and type “cmd” into the box and press ok.
  2. In command prompt type “ipconfig”.
  3. A bunch of shit should pop up, these are your different types of connections. There might be stuff like Hamachi (if you use it) and Tunngle (if you use it) but you want to find what your real internet connection is.
  4. Hopefully you found it. Take note of what the “ipv4” equals and what “default gateway” equals.
  5. Open an Internet browser and type whatever “default gateway” equaled into the address bar. There is a good chance that it is some thing like 10.0.0.1 or 192.168.1.1, though it doesn’t have to be.
  6. You should see a login screen, here is where most get stuck. Try putting “admin” for the username and “password” for the password. If that doesn’t work check the underside/backside of your modem/router for what looks like login information and try that. If none of that works then there is a good chance someone changed your log in info and you’ll need to find it from them.
  7. You should be logged in now. Look for something called “Port Forwarding”. It could be grouped in an advanced section or firewall section.
  8. This is different for everyone depending on their router but once you’re on the port forwarding page look for something like “Add Service” or somewhere that is asking for the following information: Service Name, IPv4, start port, end port.
  9. If you found this put “gmod” for service name, the ipv4 you saved earlier for the IP address field, 27015 for start port, 27020 for the end port, set the type to UDP/TCP, and save.

Restart Gmod if it was open when you did this. Now if you create a multiplayer game from your gmod your friend should be able to join you.

Everything here is great advice, the only thing I’d change is not using 27015 to 27020. Only open the ports needed, so 27015-27015 then increase to 27015-27016 if you want to run a second server.

But maybe I’m just being OTT. I just prefer not to leave open ports if I don’t need them.

Yeah maybe going up to 27020 is unnecessary but 27015 and 27016 should both be open because sometimes gmod just feels like opening on 27016.

I already did that, and I uploaded the pic above.
but still not responding :frowning:

This is usually not effective but make sure in console you run “sv_lan 0” and that your server is VAC secure with the latest gmod update installed. Also make sure its booting correctly and that is has a map loaded.

I can join the server and its work in LAN, also it’s sv_lan 0 with VAC secure, but what did u mean booting correctly ? :what: I’m sorry but I’m new to this.

Is your friend joining the server using the local ip, or is he using your external ip. You should visit https://www.whatismyip.com/ and find your external ip. Then, connect to the server using the console. Type ‘connect xxx.xx.xxx.xx:27015’ and it should work, assuming the server ports are properly portforwarded.

he used both but nothing works :frowning:

You need to open Windows Firewall ports as well.

  1. Go to the Start Menu
  2. Type in the search box ‘windows firewall’ then click ‘Windows Firewall’ or ‘Windows Firewall with Advanced Security’.

  1. If you clicked ‘Windows Firewall’ then on the left of the new window, click ‘Advanced settings’. If you clicked ‘…with Advanced Security’ then you’ll already be there.

  1. Select ‘Inbound Rules’ from the left pane.
  2. In the right pane, click ‘New Rule…’

  1. Select ‘Port’ radio button, then click ‘Next’.

  1. Make sure ‘TCP’ is selected at the top.
  2. Enter the same port range as you opened on your router firewall. Eg, 27015 or 27015-27016. Use - between two ports to include the whole range, or separate individual ports by commas. Then click ‘Next’

  1. Make sure ‘Allow the connection’ is selected, then click ‘Next’.

  1. Click ‘Next’ again.
  2. Give it a name, eg ‘Garry’s Mod TCP’, then click ‘Finish’.

  1. Repeat steps 5-11 but on step 7 make sure ‘UDP’ is selected.

If the above does not allow your friend to connect still, try temporarily disabling your windows Firewall. This will ensure it’s not a Local PC Firewall Issue. To do this, do steps 1-3, making sure you choose ‘Windows Firewall’ and not ‘…with Advanced Settings’. On the left, choose ‘Turn Windows Firewall on or off’. For both options ‘Private’ and ‘Public’, select ‘Turn off Windows Firewall (not recommended)’.

Try and get him to re-connect. If it does work, then you need to re-read the steps above, if it still doesn’t work, then it’s not your local firewall blocking it… and we’ll have to re-look over your router configuration.

Make sure to re-enable your Firewall by re-selecting ‘Turn on Windows Firewall’ for both ‘Public’ and ‘Private’ once done.

If disabling your firewall makes it work DO NOT… I repeat… DO NOT… once more… DO NOT leave your Firewall off. Make sure to turn it back on. Again - Make sure to TURN IT BACK ON. We got that? Cool. Just in-case we’re unclear, I’m going to repeat myself three times under this sentence.

Make sure to turn your firewall back on
Make sure to turn your firewall back on
Make sure to turn your firewall back on

Cool, we got that now.

thank you I will try this when I’m home and I will reply you :smile:

i think you’re starting the server with your local IP not your ext. one by how you explain it

my server IP is starting with 192.168… and that’s my IPv4 IP

Yeah, that is your internal IP, you must give your friends or w/e you external IP ( shown on whatismyip websites ), naturally your firewalls must all be “port forwarded” as well as your router must have port forwarded 27000-27030 range for your internal IP.

that doesn’t work :frowning: not forwarding the firewall or turn it off, so whats the plan? please guys I need a solution.