My Friends And I Cannot See/Connect To Dedicated Server Hosted On My PC

I can’t seem to connect to my dedicated server, and it’s not showing up on the server list.

  • sv_lan is 0* (sorry, typo)

  • autorun.bat is this: “start /wait srcds.exe -console -game garrysmod +clientport 27005 +hostport 27015 +maxplayers 32 +exec server.cfg +host_workshop_collection REDACTED +sv_setsteamaccount REDACTED”

  • Tried setting -ip 192.168.0.9 and +ip REDACTED but it comes back with “Couldn’t allocate server IP port”

  • Final message in server console is “Network: IP 192.168.0.9, mode MP, dedicated Yes, ports 27015 SV / 27005 CL”

  • Ports for TCP and UDP 27005-27020 are opened

  • Ports show as open through yougetsignal and canyouseeme

  • Port shows close when server off, open when running (as per usual)

  • Static IP set up for LAN on PC

  • Reset TCP/IP stack and winsock, reboot PC

  • Tried with and without Port Triggering

  • Deleted and reinstalled Garry’s Mod Server (4020)

  • Validated and forced app update

  • Installed server on another computer

  • Tried hard resetting my router and re-creating port forwarding

  • Have NOT tried connecting externally from my network but no one else I ask can find or connect to it

  • Tried connecting my client through host computer and another computer on network

  • Tried setting client port to 27006 and host port to 27016 through Gmod console

  • Tried connecting through console with “connect 127.0.0.1”, “connect 192.168.0.9”, “connect REDACTED” (the wan IP) and “connect localhost”

  • Added exceptions for firewall on PC by program and by port

  • Tried disabling firewall on PC

  • Antivirus is disabled

  • Dedicated server is not seen on multiplayer list, through legacy browser, favorites or local network games.

Computer stats I am hosting on:

  • Alienware 13 R3•
  • 32 GB RAM (upgraded from 16GB)
  • NVIDIA® GeForce® GTX 1060 with 6GB GDDR5
  • 7th Generation Intel® Core™ i7-7700HQ (Quad-Core, 6MB Cache, up to 3.8GHz w/ Turbo Boost)
  • 256GB SSD Drive•
  • Windows 10 Professional
  • Spectrum Internet 300mbps down/20mbps up
  • Modem Arris DG1670A
  • Tried wireless and wired

Picture of Port Forwarding:

Any suggestions?

sv_lan should be 0.

Additionally, every port forward checking website checks TCP only, not UDP. In Source, TCP is used for RCON, and UDP is used for joining the server. You also only need to forward one port for the server (27015 by default).

I believe I’ve tried both, but I believe that’s a mistype, should have posted 0.

Think I should skip all the other ports and simply port forward UDP 27015 only?

It’s what I do.

I missed the bit where you said that you couldn’t connect to your own server. In my experience, Windows Firewall is a bitch. When adding a new rule for a program, I often have to turn it off and back on before it actually takes effect.

Shouldn’t I be able to connect locally even when it’s not port forwarded?

You should. Port forwarding is only relevant for getting your friends onto your server. If you can’t join it, then I suspect an issue with firewall software on your computer (such as Windows Firewall). After making sure that a valid rule exists for your dedicated server, try turning it off from the control panel, and then back on.

Updated port forwarding to 27015 only on UDP: No change
Turned rule for Windows Firewall off then on: no change
Disabled Windows Firewall: no change

Should I setting my +IP as my external IP address or leaving that blank? It always comes back as my local LAN IP when it finishes loading

Have you started a map on your server? It doesn’t pick one by default, and if a map isn’t loaded, it effectively isn’t running.

Holy cow, that worked! Looks like it failed to load my map in startup. I can connect and so can others!

Thanks a million!