My Garrys Mod start up screen is invisible

PLEASE HELP

So i’ve had this bug for around a week now and its frustrating me, now i have tried deleting my appcache, re-downloading garrys mod, re-downloading steam deleting my .blob file, deleting my whole steam folder and re-installing steam, nothing seems to work. I looked around for any solutions but have not found any, the only way for me to even play garrys mod is to validate my files then play, when i exit gmod i have to keep repeating this step over and over and over upon loading up garrys mod, so what i have gathered is everytime i validate garrys mod it keeps giving me the same error “35 files failed to validate and will now be required.” so it keeps deleting the same 35 files over and over once i close gmod.

Some screenshots
http://cloud-4.steampowered.com/ugc/486688430000437259/B61103C54F0B84DE011B4B0A009682A3E5EC91B0/

http://cloud-4.steampowered.com/ugc/486688430000571371/6E4E3BC77F33749803B25F875630D3A6779CA208/

So when my garrys mod works, theres no errors in the console, then when my garrys mod bugs out i receive this error

 SyntaxError: Unexpected identifier
    at eval (native)
    at asset://garrysmod/html/js/thirdparty/jquery.js:2:11530
    at Function.globalEval (asset://garrysmod/html/js/thirdparty/jquery.js:2:11540)
    at HTMLScriptElement.bp (asset://garrysmod/html/js/thirdparty/jquery.js:2:3293)
    at Function.each (asset://garrysmod/html/js/thirdparty/jquery.js:2:11937)
    at [object Object].domManip (asset://garrysmod/html/js/thirdparty/jquery.js:4:1920)
    at [object Object].append (asset://garrysmod/html/js/thirdparty/jquery.js:3:31818)
    at [object Object].<anonymous> (asset://garrysmod/html/js/thirdparty/jquery.js:4:776)
    at [object Object].c [as html] (asset://garrysmod/html/js/thirdparty/angular.js:18:419)
    at k (asset://garrysmod/html/js/thirdparty/angular.js:145:78)

Edit: i checked some firewalls, virus protection systems etc and garrys mod isnt being blocked 

[http://i60.tinypic.com/2qu3fv9.png](http://i60.tinypic.com/2qu3fv9.png)

EDIT
I'm sorry for wasting everyone's time i truly am, i checked my disk defrager and looked in the logs and it was deleting gmod html caches and gmod files because they showed up as corrupt thank you for all your help though. :)

HTML errors, interesting, do you happen to be on a Mac or Linux?

Make sure you have put GMod or Steam folder into exceptions for your anti virus, it might be deleting files.

I dont have linux or mac, i have a custom built pc with windows 7 pro, i’ve never had this problem before untill just last week.

My specs
Processor: Intel Xeon E5506 @ 2.13 GHz 2.13 GHz
Ram: 12 GB
System type: 64 bit operating system
GPU: GeForce GTS 450 premium zotac boost 1GB DDR5
Motherboard: Gigabyte GA-7PESH1

Make sure a Windows is updated, and try opening command prompt and type sfc /scannow

It will do a scan and check for broken files