My Garry's Mod Won't Start Up

My gmod won’t start up. I run it, then it says it is launching gmod. Then the launcher disappears as it normally does and my cursor is indicating that it’s loading, but then it just stops and nothing happens. What do I do?

  1. Restart your computer
  2. Verify Games Cache
  3. Take out all addons
  4. Clean reistall

Try them in that order

Other people have had this problem - I would advise you to look through some threads before posting if you can help it. You may get your answer faster.

Navigate to your …/steam/steamapps/<username>/garrysmod/ folder and delete the folder named bin.

The above method worked for me when I had the same problem.

IF the above wont help - right click gmod in steam , properties , Launch Options

And type that in :


 -fullscreen 

I’ve been having this problem too… I tried deleting the clientregistry.blob no luck… Tried a bunch of different things, didn’t work, even reinstalled… still didn’t work.

Honestly have no idea what this problem is…

[editline]9th January 2011[/editline]

right, i tried everything under the sun… now i’m reinstalling steam (which wiped all my dman steam games too) so if this dont work, then its a source problem… ill let you all know how it goes…

didnt fucking work… nuff said, I now need to redownload like 120gb worth of games just to know that valve fucked up yet again… they have really been messing up alot recently, ive not been able to play TF2 due to insane random fps drops and some other source related issues…

its not you… its valve…

the end.

Did you try the -dxlevel 81 in your launch options? This worked for me.