My Gmod server through TCAdmin is returning "Query errors"

Hi, I develop for a semi-popular garrysmod server, and we haven’t been able to get it working since this most recent update. Me and the owner have found out that the error is due to the “Query failure limit being reached” (Screenshots at http://d.pr/i/dCCg and http://d.pr/i/5qC0). I’ve tried to re-install the server numerous times, I’ve even gone so far as to delete every file and install an updated server I got from another server owner’s server, and change my commandline to their command line. None of this has worked, and I’d appreciate it if anyone could help me sort this out.

[editline]17th June 2013[/editline]

I should also add that I get this error when starting the server:
http://d.pr/i/NZ0j

Does no one know the answer to this? I’ll post more information if needed.

http://www.youtube.com/watch?v=iRwJSWu-O-8 there you go

That didn’t help at all. There’s no steam update fix button, and when I delete the bin file (There’s only one) and run steam update it installs the old server.

[editline]17th June 2013[/editline]

If it helps any, this is what my server screen says when the server is “running”
http://d.pr/i/ePc2

Make a ticket to your GSP?