My Gmod will not start, any ideas on how to fix it?

I bought the counterstrike source/ gary’s mod pack off of steam any the gary’s mod does not work. I can run counter strike and half life 2 perfectly fine but whenever I try to load up gary’s mod the screen comes up then it says that hl2.exe stopped working and it never gets past that. I need some help. What’s to point of buying something that does not work.

My specs are:
-Toshiba satellite laptop
-windows vista home premium

  • 4.0 GB RAM
    -Intel® Core™2 Duo CPU T6400 2.00 GHz

I feel like I’ve tried everything please help!

I seem to have the same problem.

Yeah well, I went to another site to find some help and now as soon as I press the launch button it tells me that it can’t connect to the master pipeline and now none of my steam games work!!

can ya atleast give out your video card model please and calm the fuck down?

This might be due to the scheduled downtime, try again in 2 hours.

The only time it should be down because of VAC.

my video card is a mobile Intel series 4 chip set family , and the error message now is:

Steam Startup0 failed: SteamStartup (0xf00017EOE4) failed with error 1:
failed to take master pipe connection lock

The mods seriously need to ban people who keep making these bloody threads.

Restart steam.

“The mods seriously need to ban people who keep making these bloody threads.”

well maybe people would stop making these threads if people gave them good solutions.

  1. Search bar

  2. “Reply” button.

/sign

Well… I have the same problem. Thats what i tried:

  1. Fully reinstalled Steam with CS, Portal and GMOD
  2. Kept Vanilla GMOD
  3. tried to give admin rights to Local services (this was one solution i found)
  4. -dxlevel 80;70.
  5. move around some files (many solutions this way nothing worked)
  6. in fear of something got destroyed in 5. reinstalled gmod again.
  7. reinstalled GC drivers; and directX
  8. WTF STEAM?

No matter if i join online or singleplayer. When the loading Bar is full, i get Hl2.exe stopped working.

Any more ideas?

mfg, Xaser

yeah I tried most of those too but mine is still the same way, I wish I knew how to fix it.

Ok, so I went into the folder where all the gmod files are kept and clicked on one called hl2, with the same symbol as the game. When I click in it it gives me this error message:

SteamStartup0 failed:(0xf,0x0017E584) failed with error 1:
Failed to create pipe 6, Win32 Error 6 “the handle is invalid”

I have half life 2 and CSS installed and it works. Does any of that help figure out what the problem is?

Yep mine too, but i think thats because hl2.exe doesnt know what to load. it seems its the same exe as in portal. It needs params to load the right game?

mfg, Xaser

it says win 32 , maybe that means I need to install winzip?

Steam, Games, Garry’s Mod > Properties, Set Launch Options. Try seeing if having “-dxlevel 81” in there works. GMod didn’t for me, until a friend told me to do that.

That didn’t seem to work for me, I’ll guess I’ll try something else.

Edit: Tried reinstalling GMod but it didn’t work, I also tried restarting Steam, but alas that didn’t work.

Okay i am now in belief its an update that broke it and not our shitty hardware. Solution = Wait for an update.

No Win32 is Windows 32 Bit System.

I also think its an update… But i didnt install such updates in the near past. :7

Mfg, Xaser

EDIT: Just found my problem. my problem was -heapsize 2147483648 try to delete it if you have it!
But why isnt this working anymore?

idoit -_-

[editline]02:09PM[/editline]

what do you mean?

(none off the unedited has to do with my reply