My map is causing missing map errors, on every server.

So anybody who tries to play my map is getting the missing map error in my latest compile, beta7. I didn’t think it could be a mapside issue, but something is up. This hasn’t happened any of my previous releases. Any solutions? This is in CS:S by the way.

Here’s the full error message. It’s the same on any server hosting my map:

Connecting to 198.143.162.202:27015…
Connected to 198.143.162.202:27015

Counter-Strike: Source
Map: ze_infested-industry_v2_beta7
Players: 1 / 50
Build: 4833
Server Number: 1

Missing map maps/ze_infested-industry_v2_beta7.bsp, disconnecting

Host_Error: Disconnected

Ty

They’re missing the map, obviously. Add this command to the server.cfg file


sv_allowdownload 1

That should do the trick.

Earlier versions of my map have never caused errors before, but this recent compile seems to be causing problems. I recompiled and renamed. Still an issue. It isn’t anything serverside, it can’t be.

HAve you tried doom’s fix?

Enabling download will -should- work. If someone needs a map while connecting to a server, the server will automatically send them the map it’s running.

These are some of the biggest zombie servers on CS:S. They run maps far bigger than mine, and they are ALL getting the same error. It is not a serverside problem.

Yes, but have to tried doom’s fix?

He’s stubborn so of course not :v:

Yes. Most of the servers have the command running and still no workie.

There’s a difference between being stubborn, and responding to people who don’t understand the issue.

[editline]23rd May 2012[/editline]

Solved the problem by updating my compiler. Don’t know what happened there.