My own addon doesn't work!

I’ve downloaded resistance and liberation and I took the models and materials for vehicles and I add a info for the addon but when I try to spawn it ingame it’s spawn as a ERROR.

Can someone tell me what i’m doing wrong?

Did you do the ‘info’ file correctly?

Check that it has all the models and materials.

My addon info is this
“AddonInfo”
{
“name” “RNl MOD content”
“version” “0.1”
“up_date” “The day it came out :)”
“author_name” “Beat the zombie”
“author_email” “None”
“author_url” “None”
“info” “Mod content”
“override” “0”
}

I’ve tried and it’s doesn’t work at all.

Anybody know why it’s not working?

Take a screenshot of the addon folder so we can see if it’s set up right.

doesnt work because YOU ARE NOT THE AUTHOR!

It being in addon format has nothing to do with it being an error. You fucked something up in the model folder, or if you have a spawnlist, that may be fucked up.

This has nothing to do with it, either. Don’t be daft son.

Also, you don’t need to put anything except a letter in the info.txt. You can delete everything in there and just put “Poop” and it would still work. Putting the addon info just makes it show up in the GMod options menu, and I don’t know anybody who actually looks at that.

so my 2 cents right there

How do you even open that old Addon menu? I thought Garry disabled or deleted it when we switched to OB.

This is what I paste from the mod:

http://img94.imageshack.us/i/modelsx.png/

http://img94.imageshack.us/i/materials.png/

uh I think you need the models in folders? If they’re in folders in the game you took them from, they have to be in folders in the addon. No shortcuts.

So it’s like RNL/models/tiger and then every file for the tiger?

Well, if there’s files in there, put them in that folder inside your addon.

OOHHH!!! For the material is it RNL/materials/models/name of the model/mat for the model?

Yes. Make a tiger folder.

Or can you show me how to do it?

[editline]09:09PM[/editline]

Now that i’ve all make folder for every vehicle it doesn’t appear in my brower in gmod.

[editline]09:30PM[/editline]

I hate that, it always appear as an error.

If it’s an error, you’re still doing something wrong.

[editline]02:41AM[/editline]

You also have the materials completely wrong.

[editline]02:41AM[/editline]

And don’t put them all in models/tiger, silly.

[editline]02:42AM[/editline]

Put the folders exactly like they were in the RnL folders. You can’t change that.

Well you can with a hex editor, but that’s besides the point. The files shouldn’t really need to be copied manually, just select the folders in RnL’s model folder, copy to your addons name folder/models and do the same for materials.

how can I make a spawnlist?