My SDK map wont load in GMOD

Hey guys, I made a map in SDK using the HL2 engine.
I copied the file into my garrysmod/maps folder and when I go to play it, it loads for a second, then brings me back to the menu.
I had worked before, but not anymore.
Also, when the map had previously worked the map was dark, only able to see things with flashlight.

Post your compile log. Also run it through here.

Make sure there are no spaces in the bsp files name. This will make your map not work.

We don’t really need to know this.

Make sure your map has a light_environment.

[editline]02:52PM[/editline]

No they won’t. GMod can still run maps with spaces in their names. It only stops them from loading if you use


map example map

Don’t be such a smart arse. He means in the .bsp.
For example: “gm_house cool”.
Please don’t just flame everybody… for gods sake.

Stop defending that GMod can run it with spaces.
I mean sure it’s great and all, but it’s not an excuse to actually have a space in your map name.

I wasn’t trying to justify it, I was merely saying it isn’t neccessary to avoid spaces in map names.

[editline]07:05PM[/editline]

The fuck?

I mean in the .bsp too.

How was I flaming?

If you put a space in the name eg example map.bsp, the compiler will try to compile a map called example. This will confuse the hell out of it and will usually crash the compile. Still, a compile log would be handy. Could be a leak, or a entity displacement. Any compiler based issues will show nicely in a log and we will be able to help.

Otherwise its like phoning the AA and saying “my car won’t start” and expecting them to be able to fix it immediately on the phone.

make sure you ran the map not just pasted the vmf into the maps folder.

Guys…the dude knows how to compile. It isn’t pasting a vmf into maps folder, and there is probably no space in the map name. I would hazard that it could be displacement issues if they have been used…again, need compile log…