My server's Map Changer broke

My server is a TTT server. Recently the Fretta based game changer broke, and I have no clue why. The only new things I’ve added were a few new maps, and a script that plays music at the end of the round.

Heres some of the errors I get

Server cvar ‘sv_tags’ changed to garrysmod130,gm:terrortown,phxsvn,scriptenforcer
TTT: Traitor, you stand alone.
[fretta\gamemode\cl_gmchanger.lua:38] attempt to index local ‘votescreen’ (a nil value)
Warning: vgui.Create failed to create the VGUI component (VoteScreen)
TTT: Vote in progress, delaying new round by 30 seconds…
Server cvar ‘sv_tags’ changed to garrysmod130,gm:terrortown,phxsvn,scriptenforcer,ttt:custom_wea
Server cvar ‘sv_tags’ changed to garrysmod130,gm:terrortown,phxsvn,scriptenforcer,ttt:custom_wea
Warning: vgui.Create failed to create the VGUI component (VoteScreen)
[fretta\gamemode\cl_gmchanger.lua:52] attempt to index local ‘votescreen’ (a nil value)

Any ideas for troubleshooting?

These are the important lines:
Warning: vgui.Create failed to create the VGUI component (VoteScreen)
[fretta\gamemode\cl_gmchanger.lua:52] attempt to index local ‘votescreen’ (a nil value)

I think there my be a missing hook or something that is disabling the screen from running?

Bump. Still clueless here guys :frowning:

Can anyone give me a few starting ideas to trouble shoot?

Day seven with this problem :frowning:

Make sure the votescreen variable isn’t nil.

this is to say a convar is not set? (neither 0 or 1)?

[editline]21st February 2012[/editline]

Im getting this between rounds too:

19:52:03 Lua Error: ERROR: GAMEMODE:‘Tick’ Failed: [gamemodes errortown\gamemode\util.lua:107] attempt to index field ‘dt’ (a number value)

Bump

Try reinstalling it all.

I would much rather reinstall as a last resort. Isn’t there some methods of troubleshooting by using the errors i’ve provided?