My spray is visible only to me. I can't see anyone else's sprays.

This is quite a frustrating problem I have.

First to answer all the “dumb” questions:

  1. This has nothing to do with file size or image size, because those are well within the limits (342 KB, 450x450 respectively).
  2. My spray is a .vtf, and it’s saved under “garrysmod\materials\vgui\logos”.
  3. The server does not have sprays disabled.

In my config.cg file, I have the following set:



cl_allowupload "1"
cl_allowdownload "1"
mp_decals "5000"
cl_playerspraydisable "0"


I cannot add sv_allowupload and sv_allowdownload in my config.cg file, because it will always revert itself once I start up Gmod (not too surprising, because I suspect these 2 parameters are only for the server configs).

I’ve also noticed that when I go on a multiplayer server, the game does not create a “garrysmod\materials emp” folder, so this obviously means something is preventing the download of spray data from a server (and apparently the upload of my spray). However, once I sprayed my own spray on any given server, the game created the “garrysmod\materials emp” folder and stored my spray in there.

Can anyone help?

tl;dr: I can spray my spray on multiplayer servers, and I am able to see it. However, no one else on the server can see my spray, and I cannot see anyone else’s sprays on the server.

99% sure server has sprays disalbed.

Forgot to add that the server does not have sprays disabled.

And how do you know that?

Because this is a server I frequent often, and my friends on the same server were able to see everyone else’s sprays but mine.

[del]Your spray is probably too large and thus won’t appear for others.[/del]
Oh wait I can’t read.

[editline]7th June 2014[/editline]

No wait isn’t the max spray size 256x256?

It’s been increased to 512x512 for a while…

It is downscaled to 256x256, yes. You must set the spray from the options screen, it won’t work otherwise.

Bump.

I’d like a solution to this problem please.

Still no solution?