My text is black squares

Yesterday i hopped on gmod to play some darkrp. But when i did i couldn’t see any letters, they were all covered by these black boxes. I also noticed sometimes when i join a server the text is fine and slowly over the course of playing they will eventually become covered with these black boxes. http://imgur.com/aNfC7qU
I have tried disabling cloud and re-installing Gmod (deleting all local files) updating my drivers and re installing Tahoma font as per the suggestion of a forum i found. None of this did anything. Can anyone help me?

That’s weird, what operating system are you on? Try to see if its the server’s downloads that aren’t working by opening console and looking for something in red saying something like “HTTP Error http://fastdl/resource/fonts/fontname.otf”. My last idea would be to try to download DarkRP from the workshop yourself then joining a different server to see if the issue still continues.

mat_texture_limit? this effect happens when the texture limit is set low, what is yours set to?

I tried the mat_texture_limit and this came up.
] mat_texture_limit
“mat_texture_limit” = “-1”

  • If this value is not -1, the material system will limit the amount of texture memory it uses in a frame. Useful for identifying performance cliffs. The value is in kilobytes.

I also tried the things Stalker reccomended as well. There was no http error and getting a new darkrp did not prove useful. As i said as i play it gets worse, and when a new letter got blocked by this cube i saw an error message. i did not screenshot it in time, because by the time i was about to console looked like this. http://imgur.com/w3hn5I1 I will be trying to get this error message as soon as i can. And i am sorry for not replying quicker, some stuff came up. thank you for you help.

Try adding -dxlevel 95 to launch parameters.

i discovered that it was when i was cleaning my cash that the squares would disappear.
But when i joined back the boxes started appearing again. and as they would cover my letters i saw this in console in red. there were a lot of these error messages so i only copied a few of them. they were all the same anyway.
ShaderAPIDX8::CreateD3DTexture: E_OUTOFMEMORY
ShaderAPIDX8::CreateD3DTexture: E_OUTOFMEMORY
ShaderAPIDX8::CreateD3DTexture: E_OUTOFMEMORY

So, you are running out of VRAM?

Is that the case? i think ill invest in a new video card then. thank you guys for helping me.