MySQL and Database connecting

So I’ve set up my MySQL stuff and I have a local test server ( runs off my computer ) and a server that is being hosted by fragnet… My database connects and does everything right on the local test server, but for some reason it won’t do so on the actual server.

My host for the local test server is “panel.webfrag.net”, I tried that same host for the actual server and I’ve also tried “localhost”…

Also, I can’t check for any errors because for some reason it won’t log errors or anything that’s printed to console by Lua ( it prints chat and bans )

log “on”
sv_logflush “0”
sv_stats “1”
sv_logfile “1”
sv_log_onefile “0”

You probably need to add a remote access exception.

I added the remote access for the ip of the server and it still doesn’t seem to work still.

You need to give it access(to connect) in the mysql part in the remote database search it on Google images.

Search: mysql remote database access

… That’s what I said… I gave it remote access… This is what it says at the top:

Remote Database Access Hosts
You can allow external web servers to access your MySQL databases by adding their domain name to the list of hosts that are able to access databases on your web site.

Try to connect from your computer using Navicat or something similar to see if it is an issue with your code or your database.

Well like I said, my test server connects to it fine. Just the server hosted by Fragnet doesn’t want to connect.

I have a server thats hosted by FragNet and I can connect to my websites SQL using MySQL OO edition

So the host isnt the issue I beleive

Do you use “localhost” or “panel.webfrag.net” ?

panel.webfrag.net says…


If you are the web site owner, it is possible you have reached this page because:

The IP address has changed.
There has been a server misconfiguration.
The site may have been moved to a different server.
If you are the owner of this website and were not expecting to see this page, please contact your hosting provider.

Maybe you’re just using the wrong IP address.

Well it’s panel.webfrag.net:2083 to be exact

Try replacing the end of the IP on your MySQL remote access with a wildcard(Most likely *)

And is MySQL server and your server on the same IP?

I’m not sure about that, I’ll try the wildcard thing.

if you’re using “localhost” as the IP try “127.0.0.1”

It dosen’t matter if they have Apache running, the DNS redirect works fine, try pinging it.