MysQL - Xampp

Hello people,

I need help with “Xampp” i am setting it up my host expired and since i don’t use it 24/7 it would be better to use “Xampp”
When i started it up (Apache / Mysql) i added my Data to the Mysql, but when i join ingame it doesn’t work.

I added ofcourse my settings like this:

I tryed several things as IP like: localhost, 127.0.0.1, local.

BTW this is for myself not as public server.

(Do not post comments that aren’t usefull, if you’re going to wine etc then click on the “RED” X on the top right of your screen. Thank you very much :rock:

Friendly regards, Rinaldo :dance:


IP = "rinaldo.com"; //IP OF DB
USERNAME = "root"; //DB Username
PASSWORD = ""; //DB PASS
DBNAME = "rinaldo_perp"; //DB Name

You have to add this line to your hosts file that is located at


C:\Windows\System32\drivers\etc

I’m not able to edit that file, it says:

But its the only thing i’ve opened on my pc though.

You need to run your text editor as administrator.

Alternatively, try to reboot your pc and then edit it as administrator before doing anything else.

Hey i have had troubles with Xampp also but i suggest Ampps they are easier to use and setting up is more noob friendly.