mysqloo connection

Trying to connect to a remote DB (i.e not hosted by GSP) and it constantly forces the IP to 95.154.240.36 (owned by GSP)

I asked them regarding it and they said it shouldn’t force that, so any ideas what’s going on?

Tried various different scripts that connect to a db and all of them force the same IP, tried using 180.x.x.x IP and a hostname (what.ever.link.com)

Everytime the script tries to connect to db I get the Failed to connect to the database: Access denied for user ‘someuser’@‘95.154.240.36’ (using password: YES).

Am I doing something wrong which is forcing the IP or what? :s

Your database provider may not allow off-site access. Some databases limit access to local ips only. So; this may be doing one further, and denying the off-site access and redirecting you to the local server.

Remote DB is allowed by the provider, and I’ve allowed remote access to the DB from the GSPs IP

[editline]17th January 2014[/editline]

Putting the redirected IP rather than the game servers IP would be helpful, duh.

Sorted :stuck_out_tongue: thanks.