MySQLoo

Hey,

I installed mysqloo for linux and everytime i try to use the examples, with correct db info, it says
Module not found!

But im pretty sure i installed it.

Where did you зlace libraries and what names they have?

Root srcds dir (Where srcds_linux is located)

libmysql.so.16

Added that file there.
In garrysmod/lua/bin/

gmsv_mysqloo_linux.dll

What version you used? 32 bit or 64?

Also try to use addons like pointshop with mysql support. And check will you get this error or not.

32 Bit. Same Error.

Do a ldd on gmsv_mysqloo_linux.dll and post the output. It will show which libraries the module requires and which are missing


$ ldd gm_sv_mysqloo_linux.dll

Like the previous poster mentioned, make sure that you use the 32 bit version of the libmysqlclient library.
To check if 32 bit (look after ELF):


$ file libmysqlclient.so.16 | grep ELF

I see you have written that you have libmysql.so.16, but you need libmysqlclient.so.16 ! (As you want to use a mysql client API - not a mysql server API)



~/gmod/ft_build/garrysmod/lua/bin$ ldd gmsv_mysqloo_linux.dll
        linux-gate.so.1 =>  (0xf7713000)
        libmysql.so.16 => not found
        libstdc++.so.6 => /usr/lib32/libstdc++.so.6 (0xf75e1000)
        libm.so.6 => /lib32/libm.so.6 (0xf7594000)
        libgcc_s.so.1 => /usr/lib32/libgcc_s.so.1 (0xf7577000)
        libc.so.6 => /lib32/libc.so.6 (0xf73bf000)
        /lib/ld-linux.so.2 (0xf7714000)


Seems its the mysql.so, where i can find the client one?

Okay sorry, you don’t need the libmysqlclient, as mysqloo is not linked to the standard c library as I thought.

However you need the correct libmysql.so.16 you can download it here http://puu.sh/1ikIN (from Drakehawkes thread).

The file needs to be in the folder besides srcds_run.

After that do ldd again but this time like this (this will also search for the folder of your server) and post your output:



LD_LIBRARY_PATH=../../.. ldd gmsv_mysqloo_linux.dll


I fixed it, i was looking at v8 and not v8.1. Thanks for the help, with the debugging, i would still not know whats wrong!