Need Basic help with Mods...Problems with install

I have some problems installing my Mods. I am new to Garry’s mod so perhaps I am just doing it wrong?
So far I have watched a few tutorials on how to install the mods and read a couple, but the information did not help for some reason.
Here is what I have done:

  1. I have downloaded a couple mods from the Garry’s mod website.
  2. I have used the “WinRar” Program to extract the files and put them on my desktop in their own folders.
  3. I have opened a folder: C:\Program Files\Steam\steamapps\mewgirl\garrysmod\garrysmod
  4. I have tried two different methods of installing the mods:
    a) I have put the mods into the “addons” folder
    b) I have put the mods into folders in pieces, meaning I have put part of the mod that said “models” in the models folder, and the part the said materials into the materials folder.

I was pretty sure that (b) was not going to work, but (a) didnt work so I figured I might as well try. I have since deleted the mods I added.

What did I do wrong?
Thanks!

Okey, like this:

An addon with an “info” file in it should go straight into the addons folder.

An addon not having the file, should be merged with the folders in the Garrysmod directory.

Alright, I just tried that and it seemed to of worked, but then when I went into the menu (Q) and I selected my new item from my mod, a big red ERROR came up in place of the mod. I also noticed that when I opened Garry’s Mod there was some weird “syntax” error that said there was too many of something. Not sure what it said exactly. Is is possible that the mod is the problem or did I mess up putting files in the appropriate folders?
Here is what I did:

  1. I put all info.txt files into their own folder inside “Addons” folder
  2. Files within the materials folder I put inside “Materials” unless they were in a folder that already existed, then I put them in THAT subfolder.
    For example Lua mod files went into the lua folder, Materials into the materials folder except for the ones in the folder called VGUI, I put those files into the VGUI folder.
    I hope that makes sense.
    Let me know if this is correct. Thank you.