NEED help cant click on server to start playing

PLZ HELP

Repeat the steps you do to go into server, then press f1 and tell us what you see in the console, that would be the proper way to start.

just says rust

Have you tried shutting down steam and then going back in? That seems to fix a multitude of problems.

yes even tried shutting down my computer

[editline]16th December 2013[/editline]

and tried going on my friend computer

We need more information before we can help you, “plz help” doesn’t tell us anything Jake. Talk us through the steps you take and exactly what happens.

well i start the game
click play game
and wen ever i try double clicking the server i want (and tried multiple) wont let me load or anything does absolutly nothing.

And you checked the console with f1? please take a screenshot of your console just in case.

Strange. And you have tried this on different servers, right? just to see if it isn’t that one only?

yeah

Try uninstalling and reinstalling next.

well i have but ill try again

Verify integrity of cache next, if that doesn’t work. If not, I am all out of ideas, I hope someone else can help you!

100th times the charm thx for the help.

Glad it worked out, enjoy!

I’m having the same issue but when I tried to verify integrity of game cache I’m still having the same issue. I have looked at a lot of other thread about this issue and made one of my own.

Answer these things if you can. Makes life alot easier.

PC Specs

  • Operating System?
  • CPU?
  • Graphics Card?
  • Memory?

Description of Bug

  • What happens?
  • When does it happen?
  • Is it recurring?
  • If so, what do you need to do to replicate the bug?
  • Does it give any noticeable crash messages, errors, or logs?

Attempts to Fix

  • Switch Servers (check ping)?
  • Restart game?
  • Restart Steam (Exit Completely)?
  • Close other programs before starting game?
  • Verify Integrity of Steam Cache?
  • Reinstall game?
  • Restart computer?
  • Updated drivers?

Related Searches

  • Have you searched the issue online yet?
  • If so, what did you find? What have you tried?

PC Specs

  • Operating System? Microsoft Windows 7 Home Premium Edition Service Pack 1 (build 7601), 64-bit
  • CPU? Pentium® Dual-Core CPU T4500 @ 2.30GHz
  • Graphics Card? Mobile Intel® 4 Series Express Chipset Family
  • Memory? 4.00 GB

Description of Bug

  • What happens? When I go to the list of multiplayer servers they are unresponsive everytime I click on them. I am also not able to favorite them.
  • When does it happen? Everytime I am trying to play Rust.
  • Is it recurring? It occurs everytime I try to play Rust.
  • If so, what do you need to do to replicate the bug? Launch the game via Steam, click play game and try to join a server.
  • Does it give any noticeable crash messages, errors, or logs? I don’t see any errors in the console just the word Rust.

Attempts to Fix

  • Switch Servers (check ping)? I’ve tried a few different servers and I can’t join them.
  • Restart game? I’ve done this multiple times.
  • Restart Steam (Exit Completely)? I’ve done this multiple times.
  • Close other programs before starting game? Normally I only have teamspeak running but I’ve tried without it.
  • Verify Integrity of Steam Cache? I tried this after viewing this thread no changes.
  • Reinstall game? I’ve done this 3 times and used my brothers computer and still no luck.
  • Restart computer? I have not tried this but I will soon.
  • Updated drivers? Already updated.
  • Other? I also tried to play with out my firewall on but that does not help out either.

Related Searches

  • Have you searched the issue online yet? I had searched around to find similar issues but this thread was the best answer I could find for my issue.
  • If so, what did you find? What have you tried? In other threads people with the same issue were asked to post their specs. Though they normally did not get a response back about the issue.

I’d love to see the console logs of when this happens