Need help, Can't join any Gmod servers!

Basically one day I was playing on a great darkRP server (TritonRP) when after I left the game I went to go join a flood server, (After restarting Gmod) As the game was loading it froze on sending client info like my shitty laptop normally does, but it took a lot longer and then I got the error “BarbedPilot timed out.” I tried to rejoin the server and then when I loaded everything was fine for like 1 second then it said I was disconnecting to the server, and I waited for the d/c timer to run out and I didn’t regain any connection. I tried this again and the same thing happened so I went to go try and join the darkRP server and the same exact thing happened. I tried to join a different darkRP server and the same exact thing happened. Here is the console logs when I get the disconnection error. Please help!


Requesting texture value from var "$basetexture" which is not a texture value (material: pp/copy)
[Arivia] Script is up to date.
Trying to remove server entity on client! 270 
Client sending to server with no netchannel!
Client sending to server with no netchannel!
SoundEmitter:  removing map sound overrides [31 to remove, 0 to restore]
Client sending to server with no netchannel!

I checked my firewall and everything was normal, still couldn’t join ; I deleted all my addons and then tried to join, failed ; I uninstalled gmod and re-installed it then tried to join, nothing work. Please help i’ve been messing with this all day and nothing is working :l

EDIT:
Heres the logs when I get timed out to the server.
https://pastebin.com/eJULK3UA

EDIT:
After another day it just ended up solving itself. Ok then…