Need help in creating a complex collision mesh

For your information, I use 3DS MAX 2015. Anyways, I am having some trouble in creating a complex collision mesh. I have look up for tutorials on how to create a more complex collision mesh, but it only just made the process more confusing.

Currently, this is what the collision mesh looks like.
http://i.imgur.com/z48LP74.png

I have attempted to make a complex collision mesh, but it end messing up the collision mesh and I am not sure what to do.

Try adding $concave inside the curly brackets under $collisionmesh in your QC file

How accurate would you need it? what I like to do is duplicate the model, split up edge loops where you feel like it, and then cap them.

Did that. Didn’t work at all.

I want at least the collision model to cover the stick part properly, but the picture you have shown pretty much describes what I need.
Anyways, I have tried that method you mentioned first before making this thread, but it doesn’t seem to be working and I am getting this error in the code.



    SMD MODEL battleglaive_iron_phys.smd
    WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
    WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
    WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
    WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
    WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
    WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
    WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
    WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
    WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
    WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
    WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
    WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
    WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
    WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
    WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
    WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
    WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
    WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
    WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
    WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
    WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
    WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
    WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
    WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
    WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
    WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
    WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
    WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
    WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
    WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
    WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
    WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
    WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
    WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
    WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
    WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
    WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
    WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
    WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
    WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
    WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
    WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
    WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
    WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
    WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
    WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
    WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
    WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
    WARNING: Error with convex elements of battleglaive_iron_phys.smd, building single convex!!!!
    Model has 16 convex sub-parts
    Collision model completed.


This is what the collision model looks like now.

set all smoothing groups to 1.

Done that, but it doesn’t seem have to any effect.

Although, it did lower the amount of this error been printed, “WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!”
Perhaps maybe this error is causing this problem.


Working on "battleglaive_iron.qc"
    SMD MODEL battleglaive_iron.smd
    SMD MODEL battleglaive_iron_anims\idle.smd
    SMD MODEL battleglaive_iron_phys.smd
    WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
    WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
    WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
    WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!
    WARNING: Error with convex elements of battleglaive_iron_phys.smd, building single convex!!!!
    Model has 14 convex sub-parts
    Collision model completed.

Set each convex piece to a different smoothing group number. Remember to separate the collision model into simpler objects first.

Tried that. Still got the same error.

complex? maybe you’re doing it wrong. maybe you wanna throw away 2dsmax? :stuck_out_tongue:

it’s a cube for the tip of the handle, a 6er cylinder for the handle itself. and 2 or 3 distorted cubes or some nice tetraeders for the blade. should be a very efficient collision.

maybe you doing something wrong. in blender those are some minutes. :slight_smile:

Not really an option for me.

Anyways, perhaps maybe I am doing something wrong, but I am not too sure where though.

Would you mind sending me the reference file? It won’t be overly complicated, but I’ll see if I can make you a functional collision mesh to work with in your compile based on each segment.

Honestly, I rather prefer to do it myself though. So that I don’t need to ask this question again. But, sure.

If you haven’t already, read my reply to your PM to understand why I asked.

For anyone else wanting to know my reply, I’m mainly doing this for testing purposes on SevenBillion’s part. I included a very short idea of what to try, which is what I’m testing out.

I have already read your reply. Anyways, I used the quick hull function in the wallworm model tools that works similar to what you stated and I tried it out, I still keep on getting the same darn error.

http://i.imgur.com/pOqlyDE.png[/t]


WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!

This error is frustrating me. No matter what I do, the collision mesh always ends looking like this.

[t]http://i.imgur.com/ziLzLOn.png

I am not even sure what to do now. None of the methods I tried had work at all.

If changing the collision mesh didn’t work, then it may be something listed in your .QC file that might be causing the problem. Would you mind posting your .QC?


// Created by Crowbar 0.29.0.0

$ModelName "weapon/battleglaive/battleglaive_iron.mdl"

$BodyGroup "studio"
{
	studio "battleglaive_iron.smd"
}


$SurfaceProp "weapon"

$Contents "solid"

// Only set this if you know what it does, and need it for special circumstances, such as with gibs.
// $IllumPosition -10.836 0 0.125

$MaxEyeDeflection 90

$CDMaterials "models\weapon\battleglaive\"

// This list shows the VMT files used in the SMD files.
// "battleglaive_iron.vmt"
// "battleglaive_test.vmt"

$Attachment "ATTACK_POINT_START_00" "ValveBiped.Anim_Attachment_RH" -68.26 0.16 0 rotate 0 0 0
$Attachment "ATTACK_POINT_END_00" "ValveBiped.Anim_Attachment_RH" 59.38 0.16 0 rotate 0 0 0
$Attachment "ATTACK_POINT_START_01" "ValveBiped.Anim_Attachment_RH" 10.12 0.16 0 rotate 0 0 0
$Attachment "ATTACK_POINT_END_01" "ValveBiped.Anim_Attachment_RH" 59.38 0.16 0 rotate 0 0 0
$Attachment "ATTACK_POINT_START_02" "ValveBiped.Anim_Attachment_RH" -68.26 0.16 0 rotate 0 0 0
$Attachment "ATTACK_POINT_END_02" "ValveBiped.Anim_Attachment_RH" 59.38 3.11 4.05 rotate 0 0 0
$Attachment "ATTACK_POINT_START_03" "ValveBiped.Anim_Attachment_RH" -68.26 0.16 0 rotate 0 0 0
$Attachment "ATTACK_POINT_END_03" "ValveBiped.Anim_Attachment_RH" 59.38 -2.97 -3.6 rotate 0 0 0

$Sequence "idle" {
	"battleglaive_iron_anims\idle.smd"
	activity "ACT_VM_IDLE" 1
	fadein 0.2
	fadeout 0.2
	fps 1
}

$collisionmodel "battleglaive_iron_phys.smd" {
$concave
$maxconvexpieces 70
}

Here’s the .qc file.

:snip:
Tested my own .QC after removing the $concave and $maxconvexpieces lines with the collision mesh I made, and it didn’t seem to work when I looked at the model. Not exactly sure how to help at this point, sorry.

the “WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!” means you either have a non sealed element, a polygon, or an element with multiple smoothing groups. It also causes the collision to end up like it is. Make sure to cap all holes in your collision mesh, delete any floaters, and set all smoothing groups to 1.

i’d have a completely stripped template here if you wanna…

Odd, I did everything you said, but I still get the “WARNING: Model has 2-dimensional geometry (less than 0.500 inches thick on any axis)!!!” error. I must be doing something wrong in the process, but I still not sure where, though.