Need Help Rust Bug

Okay, I have just bought the game two days ago and downloaded it and started playing it yesterday 12/13/13, I got into one server and then every other server after that nothing works everytime i try to play in a server it never loads it gets stuck at the gray loading screen that says loading connecting… but never gets past it, then i tried uninstalling and reinstalling and then still nothing it didnt work i tried that another time and it started working for one server again, i tried connecting to the same servers i was able to but still nothing, I am really confused and maybe there is a bug or solution someone can help me on, I really need help because i really want to play the game, i understand its in early access but it seems to me everyone else is able to join any server and play.

This is all i get when i click and join a server if anyone can please message me some solutions or something to help i would appreciate it

.http://gyazo.com/dea63caa4fc599640405a31cb62cacca

PC Specs

  • Operating System?
  • CPU?
  • Graphics Card?
  • Memory?

Description of Bug

  • What happens?
  • When does it happen?
  • Is it recurring?
  • If so, what do you need to do to replicate the bug?
  • Does it give any noticeable crash messages, errors, or logs?

Attempts to Fix

  • Switch Servers (check ping)?
  • Restart game?
  • Restart Steam (Exit Completely)?
  • Close other programs before starting game?
  • Verify Integrity of Steam Cache?
  • Reinstall game?
  • Restart computer?
  • Updated drivers?

Related Searches

  • Have you searched the issue online yet?
  • If so, what did you find? What have you tried?

PC Specs
-Graphics - GeForce GTX 560 Ti
-CPU -AMD Athlon™ II X3 450 Processor
-Operating System - Windows 7
-Memory - 8G Ram and 800G Unused

Description of Bug
-Whenever I click on a server, official or community it seems to never actually connect, it gets stuck at the loading connecting screen and does nothing when its on it.
-It happens everytime i try to connect
-Gives no crash errors i have to cancel the game out.

Attempts to Fix
-Switch Servers - Tried it didnt work
-Restart Game - Tried it didnt work
-Restart Steam - Tried it didnt work
-Close other programs before starting game - Tried it and Never had anything else opened
-Verify Intergriy of Steam Cache - Tried it several times nothing happened
-Reinstall Game- Several Times nothing happened
-Restart Computer - Several Times nothing
-Updated Drivers - No Updates Found

Related Searches
-Found several with same issue no resources or help found on how to fix it.