Need help setting up a dedicated server

Hello,

I’m looking for help setting up a dedicated server, I’ve tried the guides found here and here but I just can’t make it work, so I’m guessing I’m doing something wrong.
I’m following the guide to the letter to step 2 where it all just seems to go wrong.
From guide 1:


./rust_server.exe -batchmode -hostname "My Server" -port 28015 -datadir "serverdata/"

doesn’t do anything
From guide 2:


RustDedicated.exe -batchmode +server.hostname "My Server Name" +server.port 28015 +server.identity "facepunchdev" +server.seed 6738

doesn’t do anything
I’ve installed steamcmd, I’ve updated the app using the app_update command but when I open the folder there is no release or debug (also my CFG map has no server.cfg in it, is that normal or is that a good pointer that I messed up)?
What I do find is a rust_server map with RustDedicated.exe and some .dlls.
Any experienced admin willing help a nub out?
Just shout out if I haven’t given enough info.

Any and all help appreciated.

That first guide is actually for linux and you just slapped .exe on there so no wonder it doesn’t work.

Define doesn’t do anything. Does it literally output nothing or are you getting an error message

Outputs nothing, no errors. I see the mistake I made at that part now, I thought I should exchange the rust_server with rust_server.exe but I should have removed the ./

Thanks for your reply, I’ll see if I can get it to work.

EDIT: Using rust_server.exe doesn’t seem to do anything (I guess that’s no surprise as the folder doesn’t have rust_server.exe)
Opening the path in cmd and trying to execute RustDedicated.exe (with or without anything afterwards like the -batchmode), gives me an error, not a valid win32 application, followed by an acces is denied in the cmd screen.

Missing


start

Correct way:



Start RustDedicated.exe -batchmode +server.hostname "My Server Name" +server.port 28015 +server.identity "facepunchdev" +server.seed 6738


Unless I misunderstand what your problem is.

I found this a little bit ago. I use a server host so it’s not really important to me but it might be helpful to you.

Adding start to the command results in the same error, not a valid win32 application.

Using the link and following the guide yields the following error in my cmd after executing his .bat file

Pressing a key afterwards just closes cmd and the folder remains empty.
I’ve tried removing the validate from the appupdate thing (as I’ve seen people in other guides say that it isn’t necessary) but the results are the same.

Thanks for all the replies so far guys, really appreciate it : )

This does not belong in your SteamCMD command, the guide’s out of date and the new version of Rust is no longer sitting on the experimental branch. It is the main branch.

If you want the development branch (i.e. the bleeding edge updates as published to @RustUpdates), use -beta development but be prepared to update your server 10x daily in order to keep up with the updates (your client will need to be on the development branch as well). However, I wouldn’t worry about this until you can get the server running at all.

“Rust Server” you should try “Rust_server”

[editline]8th February 2015[/editline]

And make sure that path exists

Ah, alright.

I’m not looking for the bleeding edge updates as you described, how would I go about setting up a server in that case if you don’t mind helping?

Look at this but Don’t do the add oxide bit.

http://forum.rustoxide.com/threads/setting-up-your-own-experimental-rust-server-with-oxide-2.5754/

It’s a good link

remove experimental just use app_update 258550 -beta

You don’t even need the -beta if you just want the main branch just app_update 258550

Using the oxide guide I have managed to get a server up and running and have been playing for a bit, all seems well.

Is there a way to also set up a legacy server with the same instruction?
Something I change somewhere?

Pretty much the same but the download command is app_update 258550 -beta legacy
I think

http://forum.rustoxide.com/threads/setting-up-your-own-legacy-rust-server-with-oxide.5467/

Useful link

Ok, I managed to get both an experimental and a legacy server running.
Thanks for all your help guys, much appreciated : )